Bug 19313 - DeflateStream incorrectly blocks, whereas Microsoft's runtime works fine
Summary: DeflateStream incorrectly blocks, whereas Microsoft's runtime works fine
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: System ()
Version: 3.2.x
Hardware: PC Linux
: --- normal
Target Milestone: Untriaged
Assignee: marcos.henrich
URL:
Depends on:
Blocks:
 
Reported: 2014-04-25 19:22 UTC by Matt Zyzik
Modified: 2014-08-04 13:04 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
test case (1.31 KB, text/x-csharp)
2014-04-25 19:22 UTC, Matt Zyzik
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Matt Zyzik 2014-04-25 19:22:30 UTC
Created attachment 6658 [details]
test case

In very simple scenarios, DeflateStream will block indefinitely on a Read for no good reason. I am attaching a simple test case to reproduce the issue. The Read returns fine and decompresses correctly with Microsoft's .NET runtime. With Mono 3.2.8 and also 3.4.0 it is broken.

See attached test case.
Comment 1 Matt Zyzik 2014-04-25 20:24:42 UTC
It appears the bug is in UnmanagedRead(..) of DeflateStream.cs. There is a loop within the method that won't return until the default buffer size of 4096 number of bytes is read. The length parameter is 4096 when the method is run.
Comment 2 marcos.henrich 2014-05-29 13:43:34 UTC
Hi Matt,

Thanks for reporting the bug and for the test case.
The pull request for this issue can be found in the link below.
https://github.com/mono/mono/pull/1066
Comment 3 marcos.henrich 2014-08-04 13:04:46 UTC
Fixed in master 8da27c63c37365e4467b2e780e3febcf59c8e0c7.