Bug 19304 - ComboBox reverts to original selection when it loses focus
Summary: ComboBox reverts to original selection when it loses focus
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: Windows.Forms ()
Version: 2.10.x
Hardware: PC Linux
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-04-25 12:16 UTC by David Moore
Modified: 2014-05-06 14:20 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description David Moore 2014-04-25 12:16:00 UTC
ComboBox is initially created with no ComboBoxStyle selected.  ComboBoxStyle is changed to DropDownList shortly thereafter. The user selects an entry on the ComboBox and then moves the focus to another control.  The ComboBox text immediately switches back to the initial value that appeared before the user changed it.

This appears to be caused by internal ComboTextBox class lost focus handler being called long after the ComboTextBox has been disposed.
Comment 1 David Moore 2014-04-29 11:01:12 UTC
A pull request has been created that corrects this problem. The link is https://github.com/mono/mono/pull/1010
Comment 2 Miguel de Icaza [MSFT] 2014-05-06 14:20:04 UTC
Applied