Bug 19191 - Microsoft.Build.Execution.BuildManager.Build(..) should build project if no build target specified
Summary: Microsoft.Build.Execution.BuildManager.Build(..) should build project if no b...
Status: NEW
Alias: None
Product: Tools
Classification: Mono
Component: xbuild ()
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks: 17430
  Show dependency tree
 
Reported: 2014-04-21 07:22 UTC by Matt Ward
Modified: 2014-04-21 07:24 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
BuildManager.Build test (4.13 KB, application/octet-stream)
2014-04-21 07:22 UTC, Matt Ward
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 19191 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description Matt Ward 2014-04-21 07:22:57 UTC
Created attachment 6621 [details]
BuildManager.Build test

Microsoft.Build.Execution.BuildManager.DefaultBuildManager.Build (parameters, requestData) should build the project when no build targets are specified in the requestData.

The following will build the project's default build target on Windows, but on Mac nothing is built.


var projectProperties = new Dictionary<string, string> ();
using (var projectCollection = new ProjectCollection (ToolsetDefinitionLocations.Registry | ToolsetDefinitionLocations.ConfigurationFile)) {
	var targetsToBuild = new string[0];
	BuildRequestData requestData = new BuildRequestData (projectFullPath, projectProperties, "4.0", targetsToBuild, null);
	var parameters = new BuildParameters (projectCollection) {
		NodeExeLocation = typeof(BuildProjectTests).Assembly.Location,
		ToolsetDefinitionLocations = projectCollection.ToolsetLocations
	};
	BuildResult result = BuildManager.DefaultBuildManager.Build (parameters, requestData);
}

Tested with Mono 3.4.0 (MonoFramework-MDK-3.4.0.188.macos10.xamarin.x86) on Mac.

The BuildEngine4.BuildProject currently only builds the project if one or more build TargetNames are specified in the BuildRequestData:

https://github.com/mono/mono/blob/mono-3.4.0-branch/mcs/class/Microsoft.Build/Microsoft.Build.Internal/BuildEngine4.cs#L129-L133