Bug 19089 - VS crashes first time opening VS Solution
Summary: VS crashes first time opening VS Solution
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 1.12.x
Hardware: PC Windows
: High major
Target Milestone: 3.1
Assignee: Adrian Alonso
URL:
Depends on:
Blocks:
 
Reported: 2014-04-16 13:23 UTC by Andrew Way
Modified: 2014-05-21 13:19 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Screenshot of Crash (20.72 KB, image/png)
2014-04-16 13:23 UTC, Andrew Way
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Andrew Way 2014-04-16 13:23:36 UTC
Created attachment 6595 [details]
Screenshot of Crash

Customer experience: 

I can’t make work Visual Studio with Xamarin. I am trying to open one of your demo projects (T-Shirts store) but VS2012  constantly crash. It looks like the trial license does not work as a business license or something like that. (see attached screenshot)
 
--- Customer Resolution ---

Please, discard my last message.
Creating a blank iOS Project in VS2012 updated mi trial iOS license and now it is working,
Time to start developing.

----

Andrew's comments:

This is a new customer - who just downloaded and installed Xamarin.

Likely the iOS and Android plugins were both installed - but no Trial was started prior to opening the SharpShirt solution.
Comment 3 Daniel Cazzulino 2014-04-22 10:23:21 UTC
Can we ask the customer to get the logs for us? The older logs before the fix would be useful to diagnose too.
Comment 4 Jose Miguel Torres 2014-05-21 13:19:30 UTC
@Andrew: VS should ask to start a trial when opening a iOS project if the user account has not previously consumed a trail period.

I have checked it out and it's working and triggering the trial option on XVS 2.00.112

As per this bug description, the user has been able to run the sharp shirt project right?  If so, I am about to set this to WorksForMe. Then, if this turns out in a reproducible issue in the future we could reopen it again.