Bug 19073 - 7.2.1.40: can not compile with google analytics (from component store)
Summary: 7.2.1.40: can not compile with google analytics (from component store)
Status: RESOLVED INVALID
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 7.2.1
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-04-16 02:36 UTC by softlion
Modified: 2014-04-16 14:32 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description softlion 2014-04-16 02:36:18 UTC
error:

Undefined symbols for architecture i386:
  "_GAIErrorDomain", referenced from:
     -u command line option
  "_GAIProduct", referenced from:
     -u command line option
  "_GAIVersion", referenced from:
     -u command line option
ld: symbol(s) not found for architecture i386
clang: error: linker command failed with exit code 1 (use -v to see invocation)

error MT5210: Native linking failed, undefined symbol: _GAIErrorDomain. Please verify that all the necessary frameworks have been referenced and native libraries are properly linked in.
error MT5210: Native linking failed, undefined symbol: _GAIProduct. Please verify that all the necessary frameworks have been referenced and native libraries are properly linked in.
error MT5210: Native linking failed, undefined symbol: _GAIVersion. Please verify that all the necessary frameworks have been referenced and native libraries are properly linked in.
error MT5202: Native linking failed. Please review the build log.



=== Xamarin Studio ===

Version 4.2.4 (build 32)
Runtime:
	Mono 3.2.6 ((no/9b58377)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 302060000

=== Apple Developer Tools ===

Xcode 5.1 (5084)
Build 5B130a

=== Xamarin.Mac ===

Xamarin.Mac: Not Installed

=== Xamarin.iOS ===

Version: 7.2.1.40 (Business Edition)
Hash: 86b1dbd
Branch: 
Build date: 2014-04-11 23:42:07-0400

=== Xamarin.Android ===

Not Installed

=== Build Information ===

Release ID: 402040032
Git revision: a160c35dac9ab9fd32eeadaa171216316d5a5133
Build date: 2014-03-12 13:55:08-04
Xamarin addins: a779416ceabd54981ce812771a4061c942e8b872

=== Operating System ===

Mac OS X 10.9.2
Darwin mac-de-minimac 13.1.0 Darwin Kernel Version 13.1.0
    Thu Jan 16 19:40:37 PST 2014
    root:xnu-2422.90.20~2/RELEASE_X86_64 x86_64
Comment 1 Sebastien Pouliot 2014-04-16 07:51:24 UTC
Please include the full build log (where "-v -v -v -v" is added to the additional mtouch arguments) and also state all the versions* (not just XI) being used.

If possible also include a test case that can be used to reproduce the issue.

* The easiest way to get exact version information is to use the "Xamarin Studio" menu, "About Xamarin Studio" item, "Show Details" button and copy/paste the version informations (you can use the "Copy Information" button).

c.c. Alex Soto (since it's from the component store).
Comment 2 softlion 2014-04-16 09:19:54 UTC
The full build log don't tell anything.

The problem is fixed after removing the google analytics component, and building my own binding (from the github repo) with the latest mtouch. I also replaced the .a file with the latest version from google.
Comment 3 Alex Soto [MSFT] 2014-04-16 11:38:22 UTC
@softlion Can you tell me what version of the component you have installed in your project? IIRC that is fixed in version 3.3.0.2 of the component available here

https://components.xamarin.com/view/googleanalytics
Comment 4 softlion 2014-04-16 11:47:13 UTC
I use to have 3.3.0, but updated to 3.3.0.2
To update i removed the component and added the 3.3.0.2 version.

I remarked later that removing the component did not remove the reference (i use TFS 2010 with all files read-only when not checked-out).

Maybe the component did not update. I keep the project like that, i don't have time to double check (or you pay me and i'll get time for you).
Comment 5 Alex Soto [MSFT] 2014-04-16 14:32:54 UTC
This was a known issue and has been fixed in version 3.3.0.2 of Google Analytics about a month ago.