Bug 19065 - Cannot deploy; Android SDK 16 cannot be found - I'm not even using this!
Summary: Cannot deploy; Android SDK 16 cannot be found - I'm not even using this!
Status: RESOLVED ANSWERED
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild ()
Version: 4.12.0
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2014-04-15 15:19 UTC by René Ruppert
Modified: 2017-06-27 00:17 UTC (History)
5 users (show)

Tags: bb
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description René Ruppert 2014-04-15 15:19:35 UTC
I'm trying to deploy the instructors' solution of XamU XAM210 to my Genymotion S3 (API Level 18) device.
In the project both target version and minimum version are set to "AUTOMATIC".

This results in:

/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/Android/Xamarin.Android.Common.targets: Error: Could not find android.jar for API Level 16. This means the Android SDK platform for API Level 16 is not installed. Either install it in the Android SDK Manager (Tools > Open Android SDK Manager...), or change your Xamarin.Android project to target an API version that is installed. (/Users/rene/Library/Developer/Xamarin/android-sdk-mac_x86/platforms/android-16/android.jar missing.) (Demo1_Lifecycle)

If I set both settings to API Level 18, I get the error below.

/Users/rene/Documents/tmp/Instructor - XAM210 - Backgrounding/instructor_code/Backgrounding.Android/Demo1_Lifecycle: Error XA0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. Reason: Could not find SDK platform directory '/Users/rene/Library/Developer/Xamarin/android-sdk-mac_x86/platforms/android-16'.  Are --sdk-dir and --sdk-version set appropriately? (XA0000) (Demo1_Lifecycle)

=== Xamarin Studio ===

Version 4.3.4 (build 0)
Installation UUID: 220dde4a-6e9c-4c80-a89e-6ef72bea0759
Runtime:
	Mono 3.4.0 ((no/d4511ef)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 304000185

=== Apple Developer Tools ===

Xcode 5.1.1 (5085)
Build 5B1008

=== Xamarin.Mac ===

Xamarin.Mac: Not Installed

=== Xamarin.iOS ===

Version: 7.2.1.40 (Business Edition)
Hash: 86b1dbd
Branch: 
Build date: 2014-04-11 23:42:07-0400

=== Xamarin.Android ===

Version: 4.12.3 (Business Edition)
Android SDK: /Users/rene/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.3   (API level 18)
		4.4   (API level 19)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

=== Build Information ===

Release ID: 403040000
Git revision: e2e118a56ebf05c9f15eafbf53379bdebded727c
Build date: 2014-03-12 15:39:07-04
Xamarin addins: 9f2eb9aed862e28ca23d2d2f34e22952087e6e4c

=== Operating System ===

Mac OS X 10.9.2
Darwin imacbuero.fritz.box 13.1.0 Darwin Kernel Version 13.1.0
    Thu Jan 16 19:40:37 PST 2014
    root:xnu-2422.90.20~2/RELEASE_X86_64 x86_64
Comment 1 Jonathan Pryor 2014-04-15 15:49:11 UTC
If you view your .csproj, is there a <AndroidUseLatestPlatformSdk/> XML element? If so, what value does it have? What is the value of the <TargetFrameworkVersion/> element?

Diagnostic build output may be helpful:

http://docs.xamarin.com/guides/android/troubleshooting/troubleshooting/#Diagnostic_MSBuild_Output
Comment 2 René Ruppert 2014-04-15 15:50:29 UTC
That was a hint in the correct direction! It was set to "Jelly Bean" which I do not have. Changed it to "Kit Kat" and and works. However the error handling points completely into the wrong direction and even encouraged me to file a bug!
Comment 3 Chris Hardy [MSFT] 2017-06-26 18:02:51 UTC
If the error is still causing problems with the latest release then please re-open this issue and we can look into creating a better error message when this situation happens.