Bug 19014 - Failure to execute NuGet targets due to missing LogStandardErrorAsError property
Summary: Failure to execute NuGet targets due to missing LogStandardErrorAsError property
Status: NEW
Alias: None
Product: Tools
Classification: Mono
Component: xbuild ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-04-13 17:00 UTC by Vagif Abilov
Modified: 2014-04-13 17:00 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 19014 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description Vagif Abilov 2014-04-13 17:00:43 UTC
I have a solution with enabled NuGet package restore option. It works on Windows using both Visual Studio and Xamarin Studio.

It fails to build however when using Xamarin Studio on Mac with the following error message:

"Error executing task Exec: Task does not have property "LogStandardErrorAsError" defined" - in nuget.targets

This is a MSBuild 4.0 feature that has not been implemented in xbuild. 

This issue was also discussed in the following thread:
http://forums.xamarin.com/discussion/15429/xs-fails-to-execute-nuget-targets-due-to-missing-logstandarderroraserror-property#latest