Bug 1901 - Both GetSystemWebProxy and DefaultWebProxy return null when a proxy is defined.
Summary: Both GetSystemWebProxy and DefaultWebProxy return null when a proxy is defined.
Status: RESOLVED DUPLICATE of bug 2680
Alias: None
Product: Class Libraries
Classification: Mono
Component: System ()
Version: 2.10.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-11-05 18:53 UTC by Simon Cropp
Modified: 2012-02-06 13:11 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 2680

Description Simon Cropp 2011-11-05 18:53:27 UTC
When a proxy is defined for the current connection it should be possible to retrieve it using on of the following

WebRequest.GetSystemWebProxy();
WebRequest.DefaultWebProxy;
Comment 1 Sebastien Pouliot 2012-02-05 12:51:07 UTC
This will work (only) if monomac.dll is available to your application (it's dynamically loaded by System.dll to query CFProxy).
Comment 2 Mikayla Hutchinson [MSFT] 2012-02-06 13:11:05 UTC

*** This bug has been marked as a duplicate of bug 2680 ***