Bug 18886 - HttpWebResponse does not implement SupportsHeaders property
Summary: HttpWebResponse does not implement SupportsHeaders property
Status: RESOLVED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: BCL Class Libraries ()
Version: 4.13.x
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2014-04-09 05:20 UTC by jackjoy
Modified: 2014-04-11 10:13 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
SupportsHeaders Not Implemented (10.41 KB, application/zip)
2014-04-11 05:21 UTC, Shruti
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description jackjoy 2014-04-09 05:20:05 UTC
It should add the following in HttpWebResponse.cs:

public override bool SupportsHeaders
{
	get
	{
		return true;
	}
}

This bug cause Microsoft.Data.Services.Client.Portable.dll not working for Mono.Android.
Comment 1 Shruti 2014-04-11 05:21:27 UTC
Created attachment 6553 [details]
SupportsHeaders Not Implemented

I am able to reproduce this issue. I created a test application and implemented code for 'SupportsHeaders' property. When I run the application, got error of 'No Implemented Issue'. I have attached project regarding same.

Application Output Info : https://gist.github.com/Shruti360/a73e0fd79e8b7ca4ccf9
Screencast of Bug : http://screencast.com/t/YY5oqPcF

Environment Info :
=== Xamarin Studio ===

Version 4.2.3 (build 60)
Installation UUID: 400bab6b-f5cd-4e84-a1d1-39f9d6414cb1
Runtime:
	Microsoft .NET 4.0.30319.18449
	GTK+ 2.24.22 theme: MS-Windows
	GTK# (2.12.0.0)

=== Xamarin.Android ===

Version: 4.12.2 (Trial Edition)
Android SDK: E:\SDK\AndroidSDK
	Supported Android versions:
		1.6   (API level 4)
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		3.2   (API level 13)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
		4.4   (API level 19)
Java SDK: C:\Program Files (x86)\Java\jdk1.6.0_31
java version "1.6.0_31"
Java(TM) SE Runtime Environment (build 1.6.0_31-b05)
Java HotSpot(TM) Client VM (build 20.6-b01, mixed mode, sharing)

=== Build Information ===

Release ID: 402030060
30c4afc300c2a39ec5300851357ce02e49dd217e
Build date: 2014-03-05 16:53:54Z
Xamarin addins: f8a9589b57c2bfab2ccd73c880e7ad81e3ecf044

=== Operating System ===

Windows 6.2.9200.0 (64-bit)
Comment 2 Jonathan Pryor 2014-04-11 10:13:29 UTC
This is fixed in XA 4.12.4, via commit monodroid-4.12-series/34d028de.