Bug 18844 - Breakpoint hit after code executes
Summary: Breakpoint hit after code executes
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General ()
Version: 1.10.x
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Enzo Heredia
URL:
Depends on:
Blocks:
 
Reported: 2014-04-07 17:58 UTC by John Miller [MSFT]
Modified: 2015-07-14 07:20 UTC (History)
8 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Repro Project (30.44 KB, application/zip)
2014-04-07 17:58 UTC, John Miller [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description John Miller [MSFT] 2014-04-07 17:58:22 UTC
Created attachment 6513 [details]
Repro Project

From Case:
In short, when setting the breakpoint, the line is executed before the breakpoint is hit, but should be executed after. In the attached sample, when placing a breakpoint on the OpenUrl invocation, the web browser is opened before the breakpoint is hit.

Expected Behavior:
The code should not be executed because there is a breakpoint set. It should only be executed once debugging is continued. 

Additional Info:
Running the solution in Xamarin Studio exhibits the (correct) expected behavior. 

Steps to Reproduce:
* Open the solution from the attached sample project. 
* Set a breakpoint on line 54 of MyViewController.cs on "UIApplication.SharedApplication.OpenUrl(new NSUrl("http://www.apple.com"));". 
* Run the app and click the button.
Comment 1 Shruti 2014-04-08 06:53:48 UTC
I have tested this issue and able to reproduce it. Steps are
1. I have opened the solution from the attached sample project.
2. Set a breakpoint on line "UIApplication.SharedApplication.OpenUrl(new NSUrl("http://www.apple.com"));"
3. Run the app and click the button.
4. URL "www.apple.com" is opened  and debugger point is highlighted.

ScreenCast Info of URL on Simulator : http://screencast.com/t/7FGVlHLlKj

Environment Info : 
MAC : 
Xcode 5.1 (5084)
Build 5B130a
Xamarin.iOS Version: 7.2.1.20 (Trial Edition)

Windows :

Version 12.0.21005.1 REL
Microsoft .NET Framework
Version 4.5.51641

Installed Version: Professional

LightSwitch for Visual Studio 2013   06177-004-0444002-02701
Microsoft LightSwitch for Visual Studio 2013

Microsoft Office Developer Tools for Visual Studio 2013 ENU   06177-004-0444002-02701
Microsoft Office Developer Tools for Visual Studio 2013 ENU

Team Explorer for Visual Studio 2013   06177-004-0444002-02701
Microsoft Team Explorer for Visual Studio 2013

Visual Basic 2013   06177-004-0444002-02701
Microsoft Visual Basic 2013

Visual C# 2013   06177-004-0444002-02701
Microsoft Visual C# 2013

Visual C++ 2013   06177-004-0444002-02701
Microsoft Visual C++ 2013

Visual F# 2013   06177-004-0444002-02701
Microsoft Visual F# 2013

Visual Studio 2013 Code Analysis Spell Checker   06177-004-0444002-02701
Microsoft® Visual Studio® 2013 Code Analysis Spell Checker

Portions of International CorrectSpell™ spelling correction system © 1993 by Lernout & Hauspie Speech Products N.V. All rights reserved.

The American Heritage® Dictionary of the English Language, Third Edition Copyright © 1992 Houghton Mifflin Company. Electronic version licensed from Lernout & Hauspie Speech Products N.V. All rights reserved.

ASP.NET Web Frameworks and Tools 2012.2   4.1.21001.0
For additional information, visit http://go.microsoft.com/fwlink/?LinkID=309563

ASP.NET Web Frameworks and Tools 2013   5.0.11001.0
For additional information, visit http://www.asp.net/

Common Azure Tools   1.0
Provides common services for use by Azure Mobile Services and Windows Azure Tools.

Microsoft Web Developer Tools 2013   2.0.40926.0
Microsoft Web Developer Tools contains the following components:
Support for creating and opening ASP.NET web projects
Browser Link: A communication channel between Visual Studio and browsers
Editor extensions for HTML, CSS, and JavaScript
Page Inspector: Inspection tool for ASP.NET web projects
Scaffolding: A framework for building and running code generators
Server Explorer extensions for Windows Azure Web Sites
Web publishing: Extensions for publishing ASP.NET web projects to hosting providers, on-premises servers, or Windows Azure

NuGet Package Manager   2.7.40911.287
NuGet Package Manager in Visual Studio. For more information about NuGet, visit http://docs.nuget.org/.

PreEmptive Analytics Visualizer   1.2
Microsoft Visual Studio extension to visualize aggregated summaries from the PreEmptive Analytics product.

SQL Server Data Tools   12.0.30919.1
Microsoft SQL Server Data Tools

Windows Azure Mobile Services Tools   1.0
Windows Azure Mobile Services Tools

Workflow Manager Tools 1.0   1.0
This package contains the necessary Visual Studio integration components for Workflow Manager.

Xamarin.Android   4.12.02001 (a1e3982a)
Visual Studio plugin to enable development for Xamarin.Android.

Xamarin.iOS   1.10.47 (3d6a125d)
Visual Studio extension to enable development for Xamarin.iOS
Comment 2 Rajneesh Kumar 2015-07-14 07:20:33 UTC
I have checked this issue with the latest stable build XVS 3.11.666 + XI 8.10.3.2 and observed that this issue has been fixed and no longer exist with this build. Now URL "www.apple.com" does't opened  and debugger point is highlighted.

Screencast: http://www.screencast.com/t/kaTNZVo1U

This issue has been fixed, hence I am closing this issue.

Thanks..!