Bug 1863 - CodeDOM code generation missing TypeArguments on CodeTypeReference instances
Summary: CodeDOM code generation missing TypeArguments on CodeTypeReference instances
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: System ()
Version: master
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2011-11-03 16:19 UTC by JohanO
Modified: 2017-02-10 08:03 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description JohanO 2011-11-03 16:19:26 UTC
Observe the following CodeDom code

CodeTypeReference typeRef = new CodeTypeReference("IPropertyObserver");
typeRef.TypeArguments.Add(new CodeTypeReference("Foo"));

It should product something like

public class Foo: ( IPropertyObserver<Foo> ) <--
{
}

instead it ignores the type arguments when I generate the code. There is something left out of the C# code generator that is in the standard .NET code DOM C# code generator??
Comment 1 Marek Safar 2017-02-10 08:03:16 UTC
Fixed in master