Bug 18593 - Problematic breakpoints not being hit, ignored and/or pointing to improper files
Summary: Problematic breakpoints not being hit, ignored and/or pointing to improper files
Status: RESOLVED DUPLICATE of bug 16916
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 1.12.x
Hardware: PC Mac OS
: High critical
Target Milestone: 3.1
Assignee: Vinicius Jarina
URL:
Depends on:
Blocks:
 
Reported: 2014-03-26 11:30 UTC by Allie Miller
Modified: 2014-04-10 10:37 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 16916

Description Allie Miller 2014-03-26 11:30:27 UTC
*Filed on behalf of a user*

Set-up:
The project where this is occurring has about 30 assemblies, most of them PCL. The solution also includes a few iOS class libraries subprojects. The build process involves external tools to add metadata and assembly signing information.

The Problem:
Debugging the subprojects is often very problematic due to some breakpoints being ignored and some being associated with a wrong source file/location. Some files in a specific project can be debugged perfectly while others are impossible to debug (with Visual Studio complaining that no symbols have been loaded for that file) unless you move them to the main application project. It has also been noted that that not only several breakpoints were ignored or pointing to wrong files, but also a few of them referring to the correct files were off by several lines, resulting in VS hitting a breakpoint and then showing empty or comment lines as the current program step (but the local variables inspector was
consistent with the correct program status).

After managing to remove some of the external tool dependencies from the project to test on the Mac Build Host, the issue doesn't seem to occur there. However, testing on a different Windows machine has resulted in the same issue.   

Versioning Information:
Microsoft Visual Studio Professional 2013
Version 12.0.30110.00 Update 1
Microsoft .NET Framework
Version 4.5.50938
Installed Version: Professional
Xamarin.Android 4.12.02001 (a1e3982a)
Xamarin.iOS 1.10.47 (3d6a125d)


On the Mac Build Host:
=== Xamarin Studio ===
Version 4.2.3 (build 60)
Runtime: Mono 3.2.6 ((no/9b58377)
GTK+ 2.24.23 theme: Raleigh
GTK# (2.12.0.0)
Package version: 302060000
=== Apple Developer Tools ===
Xcode 5.1 (5084)
Build 5B130a
=== Xamarin.iOS ===
Version: 7.2.0.2 (Business Edition)
Hash: 58c3efa
Branch:
Build date: 2014-10-03 18:02:26-0400
Mac OS X 10.8.5
Comment 5 Allie Miller 2014-04-10 10:37:43 UTC

*** This bug has been marked as a duplicate of bug 16916 ***