Bug 18537 - Installing a newer mono while XS is running breaks building open solution impossible
Summary: Installing a newer mono while XS is running breaks building open solution imp...
Status: CONFIRMED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 4.2.x
Hardware: PC Mac OS
: Lowest normal
Target Milestone: Future Cycle (TBD)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-03-22 14:36 UTC by Rodrigo Kumpera
Modified: 2017-01-23 14:32 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: No
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 18537 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Rodrigo Kumpera 2014-03-22 14:36:48 UTC
Open a desktop 4.5 solution and successfully build it.

Install a different version of mono (in my case 3.2.6 -> 3.4.1)

Try to build the solution and it will fail saying that the 4.5 profile is missing.
Comment 1 Marius Ungureanu 2014-10-07 06:17:04 UTC
Can this be closed?
Comment 2 Rodrigo Kumpera 2014-10-07 09:35:48 UTC
Was it fixed?
Comment 3 Lluis Sanchez 2017-01-13 08:52:22 UTC
Reopening so that it can be confirmed.
Comment 4 Jason Imison 2017-01-23 14:32:18 UTC
I downgraded mono from 4.8.0 to 4.6.2 whilst keeping Xamarin Studio open. The project built fine both before and after.

Then I relaunched XS and upgraded back to 4.8.0 keeping XS open again.

I got the following message

Error: /Users/jason/Projects/bug18537/bug18537/bug18537.csproj: /Users/jason/Projects/bug18537/bug18537/bug18537.csproj could not import "$(MSBuildBinPath)\Microsoft.CSharp.targets" (bug18537)

Relaunched XS once more, and the project built again (just a standard console app from the template)