Bug 1851 - Implement a Resources folder for iPhone Add-in
Summary: Implement a Resources folder for iPhone Add-in
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: 2.8
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
URL:
: 5179 ()
Depends on:
Blocks:
 
Reported: 2011-11-03 08:32 UTC by Alex P
Modified: 2012-06-25 14:38 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Alex P 2011-11-03 08:32:02 UTC
I'm trying to use in interface builder images added to my monotouch project.  I can see the images in interface builder media library, I can drag them into my view.  Everything looks good in interface builder. 

The problem is that when I run my project I cannot see the images.  I found that because my images are in a folder in my monotouch project, I need to manually add the folder name in IB ( like with older versions ).  Is this normal ?  

Also, is this the place to report this issue (if it's an issue)?  You have so many support option on your site that I don't know where to post them.
Comment 1 Sebastien Pouliot 2011-11-03 09:25:20 UTC
-> monodevelop
Comment 2 Eran Koren 2012-02-26 04:36:04 UTC
Same problem a little different on my version (see below).
Png's are not copied to temp directory under ../obj/xcode/(some number) and do not appear at all in xcode.
workaround: copy the files manually. (extremely annoying and not practical since the temp dir change each time you open a xib.)

Here is my version info:
MonoDevelop 2.8.6.5
Installation UUID: 6773337c-9128-437a-a86f-88deed2c51e9
Runtime:
	Mono 2.10.9 (tarball Tue Feb 14 20:23:29 EST 2012)
	GTK 2.24.9
	GTK# (2.12.0.0)
Apple Developer Tools:
	 Xcode 4.2 (828)
	 Build 4D199
Monotouch: 5.2.5
Mono for Android: 4.0.4.264524889 (Evaluation)
Build information:
	Release ID: 20806005
	Git revision: 96a2067d048f7e91f9515c869f214243f1926953
	Build date: 2012-02-17 03:31:11+0000
Operating System:
	Mac OS X 10.7.3
Comment 3 Eran Koren 2012-02-26 09:11:30 UTC
This should maybe be filled under a different bug, i'm seeing more problems with copying of files, this time to the deployment bundle. 
what i'm trying to do is create an additional bundle in my app to hold some nibs and resources. 
according to apples documentation giving a folder a ".bundle" suffix is enough for the system to consider it as a bundle. if i create a folder with the ".bundle" suffix the system will treat it as a bundle. but any xib i put in the folder will compile to a nib and will be put in the root of the .app structure. if i manually change the .app and move the nib's under my .bundle folder everything works fine and i can load resources and nib's from the bundle.
Comment 4 Jeffrey Stedfast 2012-04-24 15:03:21 UTC
The problem is that Interface Builder only allows top-level images to be used in .xib's, meaning that it does not store the relative path of the image, just the image *name*.

MonoDevelop has been fixed to not sync out images from anywhere except the top-level directory of the project as a temporary solution to this problem (it mostly just avoids confusion of the kind found in this bug report).

In the future, we plan to add a Resources folder where you can add your images which will also be synced out to the Xcode project and which will, when the app bundle is built, be copied tot he root level of the app bundle so that xibs which reference "foo.jpg" will work.

Renaming this bug report since we don't seem to have an official entry in bugzilla for the Resource folder feature that I could find.
Comment 5 Mikayla Hutchinson [MSFT] 2012-05-18 16:14:32 UTC
*** Bug 5179 has been marked as a duplicate of this bug. ***
Comment 6 Jeffrey Stedfast 2012-06-25 14:38:25 UTC
Implemented in git master