Bug 18465 - Xamarin.Designer.DesignerException: Exception of type 'Xamarin.Designer.DesignerException' was thrown.
Summary: Xamarin.Designer.DesignerException: Exception of type 'Xamarin.Designer.Desig...
Status: RESOLVED NORESPONSE
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android Designer ()
Version: 1.12.x
Hardware: PC Mac OS
: High normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-03-19 11:37 UTC by Allie Miller
Modified: 2016-01-26 16:37 UTC (History)
9 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Trace log (4.24 KB, application/octet-stream)
2014-03-25 09:43 UTC, Allie Miller
Details
here is part 2 (1.43 MB, patch)
2014-04-04 05:51 UTC, softlion
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Allie Miller 2014-03-19 11:37:06 UTC
Similar to #9330, but it was requested that I open a new report for this issue.

In Xamarin Studio the custom theme set is displayed properly by
the Android Designer. However, in Visual Studio, the theme does not display
properly and the resulting error is found in the logs (which I'll attach to
this bug report):

Mono.VisualStudio.Shell.ShellPackage Error: 0 : [2014-03-16 13:28:32.0] Session
initialization failed
Xamarin.Designer.DesignerException: Exception of type
'Xamarin.Designer.DesignerException' was thrown.
   at Xamarin.AndroidDesigner.JavaProcessConnection.GetResponse(BinaryMessage
message, Int32 timeout)
   at Xamarin.AndroidDesigner.JavaProcessConnection.SendMessage(BinaryMessage
message)
   at
Xamarin.AndroidDesigner.AndroidRenderSession.InitSession(DesignerSessionParams
refreshConfiguration)
Mono.VisualStudio.Shell.ShellPackage Error: 0 : [2014-03-16 13:28:32.0] Session
initialization failed
Xamarin.Designer.DesignerException: Exception of type
'Xamarin.Designer.DesignerException' was thrown.
   at Xamarin.AndroidDesigner.JavaProcessConnection.GetResponse(BinaryMessage
message, Int32 timeout)
   at Xamarin.AndroidDesigner.JavaProcessConnection.SendMessage(BinaryMessage
message)
   at
Xamarin.AndroidDesigner.AndroidRenderSession.InitSession(DesignerSessionParams
refreshConfiguration)
Mono.Android.VisualStudio.MonoAndroidPackage Error: 0 : [2014-03-17 20:28:31.5]
MonoAndroidDebuggerSession
Mono.Debugging.Soft.ConnectionException: Could not connect to the debugger.
---> System.Net.Sockets.SocketException: No connection could be made because
the target machine actively refused it 127.0.0.1:8838

Version Information
OS: Win 8.1 English, 64bit
VS 2013 SP1
Xamarin.Android 4.12.02002
Xamarin Studio 4.2.3 build 60
Android SDK Tools: 22.6.1 (however occurs in 22.6 as well)
Comment 2 Sadik Ali 2014-03-20 06:38:18 UTC
I have checked this issue but unable to reproduce this. I debug attached application successfully using VS 2013 and not getting any exception.

Refer screen shot: http://screencast.com/t/cmNF4fYReK
Debug log: https://gist.github.com/Mohit-Kheterpal/9661081

I checked trace log noticed that no exception is added.

Checked with:

Windows 8.1, 8.0
VS 2013
XA 4.12.02001
XS 4.2.3 build 60
Android SDK Tools: 22.6.1, 22.6

Please let me know if I am missing anything to check this issue.
Comment 3 Allie Miller 2014-03-25 09:42:47 UTC
Hi @Sadik!
I'm not sure why this isn't reproducible on your end, but this has been reported by another user as well :/

I confirmed with the user who is running into this issue as they are running:
VS2010
Xamarin.Android 4.12.2.1
Android SDK 22.6.1

I'll attach the Trace logs to this report.
Comment 4 Allie Miller 2014-03-25 09:43:25 UTC
Created attachment 6405 [details]
Trace log

From second reported instance of this issue
Comment 8 Jérémie Laval 2016-01-26 16:37:29 UTC
Closing for now because of inactivity. Feel free to reopen if problem still happens.