Bug 18280 - --debug with casts not working
Summary: --debug with casts not working
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: Debugger ()
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2014-03-10 10:02 UTC by Marek Safar
Modified: 2014-03-10 15:11 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Marek Safar 2014-03-10 10:02:37 UTC
using System;

public class M
{
	static void Foo<T> (object arg)
	{
		var g = (T)arg;

	}

	static int F ()
	{
		return 1;
	}

	public static void Main ()
	{
		Foo<Func<Func<int>>> (new Func<int> (F));
		return;
	}
}

mono --debug=casts test-901.exe

Unhandled Exception:
System.InvalidCastException: Cannot cast from source type to destination type.
  at (wrapper castclass) object:__castclass_with_cache (object,intptr,intptr)
Comment 1 Zoltan Varga 2014-03-10 15:11:24 UTC
Fixed in master 6b6aee8c65014f67c18e3d997f70bcaadea46883.