Bug 18260 - Slow build/deploy times. Project being built twice in VS 2013/Windows 8.1
Summary: Slow build/deploy times. Project being built twice in VS 2013/Windows 8.1
Status: CONFIRMED
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild ()
Version: 4.12.0
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2014-03-07 18:48 UTC by Jon Goldberger [MSFT]
Modified: 2016-12-20 07:04 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Test project (318.29 KB, application/zip)
2014-03-07 18:51 UTC, Jon Goldberger [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 18260 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Comment 1 Jon Goldberger [MSFT] 2014-03-07 18:51:59 UTC
Created attachment 6265 [details]
Test project
Comment 2 Jon Goldberger [MSFT] 2014-03-07 18:56:41 UTC
The project Nieron.Android in the above test solution is being built twice. Overall, this customer has been experiencing slow build and deploy times with his project. I noticed that rebuild times were not as fast as they could/should be, IOW not much faster than the initial build/deploy times after a clean build with the app not installed on the device yet.
Comment 7 Ram Chandra 2014-03-10 06:43:51 UTC
I have checked this issue with "attached project" and i am able to reproduce this issue.

Steps to reproduce:

1) Open attached project on VS2013.
2) Build/ Deploy attached project.
3) Open output window and look for "Build Started".

screencast: http://www.screencast.com/t/AvUeszeXso

Environment:

Visual studio 2013
Xamarin.Android : 4.12.00028
Xamarin.iOS for VS: 1.10.39