Bug 18244 - UIDataDetector buggy on long strings with line breaks
Summary: UIDataDetector buggy on long strings with line breaks
Status: RESOLVED UPSTREAM
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: master
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-03-07 06:40 UTC by Craig
Modified: 2014-03-13 16:48 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Controller that demonstrates the issue, by toggling the boolean "breakWithExtraLength" (10.77 KB, application/octet-stream)
2014-03-07 06:40 UTC, Craig
Details
Xcode project (16.11 KB, application/zip)
2014-03-13 16:48 UTC, Rolf Bjarne Kvinge [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED UPSTREAM

Description Craig 2014-03-07 06:40:13 UTC
Created attachment 6257 [details]
Controller that demonstrates the issue, by toggling the boolean "breakWithExtraLength"

When using long strings (greater than roughly 10000 characters), that contain line breaks, URLs and email addresses beyond roughly 10000 characters are not detected and highlighted, as they are supposed to be.

I've attached a sample controller that adds a textview and demonstrates the issue, by toggling the boolean "breakWithExtraLength".


I've also been able to recreate it, with the following:

string textViewString = "";
for(var i = 0; i < 500; i++){
     textViewString += "Test addresses test@example.com http://www.example.com \n";
}
textView.Text = textViewString;
Comment 1 Sadik Ali 2014-03-07 07:25:56 UTC
I have checked this issue on below environments:

MAC
XS 4.2.3 (Build 60)
X iOS 7.0.7.2

I followed below steps:

1. Created iOS application.
2. Implemented attached code in created application.
3. Debug and noticed that all text is not displayed on simulator.
4. Also I check with the code as mentioned with bug description and noticed that only 15 loop text is displayed on simulator.
Refer screen cast: http://screencast.com/t/EpsTxytHkmfx
Comment 2 Rolf Bjarne Kvinge [MSFT] 2014-03-13 16:47:56 UTC
I can reproduce with iOS 7.1 (iPad Air), but not iOS 6.1 (iPad 3).

I can also reproduce with an equivalent Xcode project, which means that this is not a problem with Xamarin.iOS, it's a problem with iOS.
Comment 3 Rolf Bjarne Kvinge [MSFT] 2014-03-13 16:48:35 UTC
Created attachment 6306 [details]
Xcode project