Bug 18122 - When textAppearance is set on a TextView the designer displays a placeholder
Summary: When textAppearance is set on a TextView the designer displays a placeholder
Status: CONFIRMED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android Designer ()
Version: 1.12.x
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
: 18670 ()
Depends on:
Blocks:
 
Reported: 2014-03-03 08:15 UTC by softlion
Modified: 2017-09-01 23:42 UTC (History)
10 users (show)

Tags: vs ac
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 18122 on Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.
Related Links:
Status:
CONFIRMED

Description softlion 2014-03-03 08:15:09 UTC
When the textAppearance property is set on a TextView in a layout axml file,
the designer displays a placeholder instead of the textView, as if it did not recognize it anymore.
Comment 1 Sadik Ali 2014-03-03 09:28:32 UTC
I have checked this issue on below environments:

Windows
VS 2012
XS for VS 1.12.217.0

I am unable to reproduce this refer screen. Refer screen cast: http://www.screencast.com/t/v36oZRWtsd. Please give provide me some details so that I can check this issue.
Comment 2 softlion 2014-03-03 10:31:00 UTC
Well in the screencast you have reproduced the problem.

The designer should not display "TextView", but the text set in the "text" property.

Also, you should not put anything you want in the textAppearance property. It have to be an existing style:

@style/myStyle


myStyle should be defined in a style.xml file.

In fact you know nothing about Android app creation/designer do you ?
I don't have time to teach you sorry.
Comment 3 Sadik Ali 2014-03-04 08:45:32 UTC
I have checked this issue and I am able to reproduce this issue as mentioned in Comment#2 and in Bug Description.
Refer screen cast : http://www.screencast.com/t/fvskt6s7Xbu

Checked With:

Windows
VS 2012
XS for VS 1.12.217.0
Comment 4 Lluis Sanchez 2014-05-08 13:12:15 UTC
*** Bug 18670 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Kolb 2015-02-19 14:17:46 UTC
I'm seeing this too.
Comment 6 Jeremy Kolb 2015-02-19 14:21:48 UTC
If I use textAppearance="TextAppearance.AppCompat.Title" I see this.  If I use my own style that inherits from TextAppearance.AppCompat.Title or includes that in it's textAppearance then the TextView shows up in the right place but has a 0 height and no text in the designer.
Comment 7 Kent Green [MSFT] 2017-07-07 23:51:02 UTC
I tried to check if this issue is reproducible in Visual Studio for Mac on the Alpha channel, but even after viewing the attached screencast I'm confused about what the expected vs. actual behavior & reproduction steps are. As such I cannot confirm whether or not this issue is reproducible in Visual Studio for Mac.

If this issue is reproducible in Visual Studio for Mac, can you include your full version information from "Visual Studio > About Visual Studio > Copy Information"?
Comment 8 softlion 2017-09-01 06:53:12 UTC
Closing the issue, as using Android Studio is much easier and faster (using XamarIdea to create the initial android studio project).
Comment 9 Kent Green [MSFT] 2017-09-01 23:42:34 UTC
Sorry for any possible confusion. My statement in comment 7 was with regard to this bug's reproducibility specifically in Visual Studio for Mac; which I was unable to determine. However, my statement was not intended to modify the "CONFIRMED" status based on the results in comment 3, which refer to reproducibility in Visual Studio for Windows.

As such, I am setting this bug as CONFIRMED once again, since this bug has not been fixed.