Bug 18100 - Stepping failed due to ERR_UNLOADED
Summary: Stepping failed due to ERR_UNLOADED
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Runtime
Classification: Mono
Component: Debugger ()
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Zoltan Varga
URL:
: 11559 ()
Depends on:
Blocks:
 
Reported: 2014-02-28 15:52 UTC by Mikayla Hutchinson [MSFT]
Modified: 2017-04-28 09:31 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Mikayla Hutchinson [MSFT] 2014-02-28 15:52:35 UTC
Debugging XS on with Mono master, hit a breakpoint, attempted to step. Debugger stuck in limbo, and error log shows:

ERROR [2014-02-28 15:45:29Z]: Step request failed
Mono.Debugger.Soft.CommandException: Debuggee returned error code ERR_UNLOADED.
  at Mono.Debugger.Soft.VirtualMachine.ErrorHandler (System.Object sender, Mono.Debugger.Soft.ErrorHandlerEventArgs args) [0x00076] in /Users/michael/Mono/monodevelop/main/external/debugger-libs/Mono.Debugger.Soft/Mono.Debugger.Soft/VirtualMachine.cs:302 
  at Mono.Debugger.Soft.Connection.SendReceive (CommandSet command_set, Int32 command, Mono.Debugger.Soft.PacketWriter packet) [0x000f9] in /Users/michael/Mono/monodevelop/main/external/debugger-libs/Mono.Debugger.Soft/Mono.Debugger.Soft/Connection.cs:1448 
  at Mono.Debugger.Soft.Connection.EnableEvent (EventType etype, SuspendPolicy suspend_policy, System.Collections.Generic.List`1 mods) [0x003b1] in /Users/michael/Mono/monodevelop/main/external/debugger-libs/Mono.Debugger.Soft/Mono.Debugger.Soft/Connection.cs:2207 
  at Mono.Debugger.Soft.EventRequest.SendReq (System.Collections.Generic.List`1 mods) [0x000bf] in /Users/michael/Mono/monodevelop/main/external/debugger-libs/Mono.Debugger.Soft/Mono.Debugger.Soft/EventRequest.cs:106 
  at Mono.Debugger.Soft.StepEventRequest.Enable () [0x0004b] in /Users/michael/Mono/monodevelop/main/external/debugger-libs/Mono.Debugger.Soft/Mono.Debugger.Soft/StepEventRequest.cs:52 
  at Mono.Debugger.Soft.EventRequest.set_Enabled (Boolean value) [0x00015] in /Users/michael/Mono/monodevelop/main/external/debugger-libs/Mono.Debugger.Soft/Mono.Debugger.Soft/EventRequest.cs:50 
  at Mono.Debugging.Soft.SoftDebuggerSession+<Step>c__AnonStorey6.<>m__0 (System.Object ) [0x00086] in /Users/michael/Mono/monodevelop/main/external/debugger-libs/Mono.Debugging.Soft/SoftDebuggerSession.cs:1211
Comment 1 Zoltan Varga 2014-03-05 14:38:53 UTC
*** Bug 11559 has been marked as a duplicate of this bug. ***
Comment 2 Zoltan Varga 2014-03-05 14:42:38 UTC
Added some debug output to master/3.4.0 which will print something like this to sdout when the error
happens:
ERR_UNLOADED, id=<id>, type=<type>
Comment 3 Zoltan Varga 2015-01-08 05:45:39 UTC
I can never reproduce this. Please reopen if still happens.