Bug 1809 - Errors while syncing back from xcode
Summary: Errors while syncing back from xcode
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: Trunk
Hardware: PC Mac OS
: High normal
Target Milestone: ---
Assignee: Alan McGovern
URL:
Depends on:
Blocks:
 
Reported: 2011-11-01 12:07 UTC by Alan McGovern
Modified: 2011-12-29 05:38 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Alan McGovern 2011-11-01 12:07:34 UTC
When I try to reopen a form that I had just created the following error is thrown from monodevelop

“System.IO.DirectoryNotFoundException: Directory '/Users/stavrosmenegos/Projects/ESMobile/iSFA/gr.entersoft.esmobile/gr.entersoft.esmobile/obj/Xcode/11' not found.

at System.IO.Directory.ValidateDirectoryListing (System.String path, System.String searchPattern, System.Boolean& stop) [0x000cd] in /private/tmp/monobuild/build/BUILD/mono-2.10.6/mcs/class/corlib/System.IO/Directory.cs:483 

at System.IO.Directory+<EnumerateKind>c__Iterator0.MoveNext () [0x00044] in /private/tmp/monobuild/build/BUILD/mono-2.10.6/mcs/class/corlib/System.IO/Directory.cs:532 

at MonoDevelop.MacDev.XcodeSyncing.XcodeMonitor.ScanForAddedFiles (MonoDevelop.MacDev.XcodeSyncing.XcodeSyncBackContext ctx, System.Collections.Generic.HashSet`1 knownFiles, System.String directory, System.String relativePath) [0x000e7] in /private/tmp/source/monodevelop/main/src/addins/MonoDevelop.MacDev/XcodeSyncing/XcodeMonitor.cs:194 

at MonoDevelop.MacDev.XcodeSyncing.XcodeMonitor.GetChanges (IProgressMonitor monitor, MonoDevelop.MacDev.ObjCIntegration.NSObjectInfoService infoService, MonoDevelop.Projects.DotNetProject project) [0x00043] in /private/tmp/source/monodevelop/main/src/addins/MonoDevelop.MacDev/XcodeSyncing/XcodeMonitor.cs:241 

at MonoDevelop.MacDev.XcodeSyncing.XcodeProjectTracker.SyncXcodeChanges (IProgressMonitor monitor) [0x00017] in /private/tmp/source/monodevelop/main/src/addins/MonoDevelop.MacDev/XcodeSyncing/XcodeProjectTracker.cs:351”

followed by this exception

“System.NullReferenceException: Object reference not set to an instance of an object

at MonoDevelop.MacDev.XcodeSyncing.XcodeProjectTracker.OpenFileInXcodeProject (System.String path) [0x00056] in /private/tmp/source/monodevelop/main/src/addins/MonoDevelop.MacDev/XcodeSyncing/XcodeProjectTracker.cs:166”

Keep in mind that this is not consistent. Most of the times it works fine.
Comment 2 Alan McGovern 2011-11-22 07:51:42 UTC
I've requested more info from the original reporter. I cannot reproduce this issue.
Comment 3 Alan McGovern 2011-12-14 07:03:06 UTC
I think i fixed this issue a while ago. We weren't cleaning up properly which resulted in this exception being thrown after we deleted the temp directories.
Comment 4 Saurabh 2011-12-29 05:38:45 UTC
Please provide steps so that we can verify this issue.

Kindly change status to NEEDINFO.