Bug 17963 - No lint on Xamarin.Android
Summary: No lint on Xamarin.Android
Status: RESOLVED DUPLICATE of bug 8377
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: 4.12.0
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2014-02-24 06:34 UTC by Horácio J. C. Filho
Modified: 2014-02-24 13:37 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 8377

Description Horácio J. C. Filho 2014-02-24 06:34:05 UTC
In Xamarin.Android there is no lint static tool, is there some workaround?

Xamarin.Android is wonderful XD
Comment 1 Jonathan Pryor 2014-02-24 13:37:31 UTC
You may use the Android SDK `lint` tool, in $ANDROID_SDK_PATH/tools/lint.

http://lists.ximian.com/pipermail/monodroid/2012-October/012572.html

One problem is that current Xamarin.Android generated output is not "lint-free", i.e. it can produce many warnings, some of which we should fix. Please see Bug #8377.

*** This bug has been marked as a duplicate of bug 8377 ***