Bug 17902 - Not seeing 'PNGCrush' in build output after selecting 'Optimize PNG image files for iOS'
Summary: Not seeing 'PNGCrush' in build output after selecting 'Optimize PNG image fil...
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 1.12.x
Hardware: PC Windows
: Normal normal
Target Milestone: 4.0.0 (C6)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-02-20 01:41 UTC by narayanp
Modified: 2015-09-24 08:36 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description narayanp 2014-02-20 01:41:32 UTC
Steps to reproduce:
1. Open or create iOS application in VS.
2. Open Project Properties->iOS Build.
3. Select check-box 'Optimize PNG images file for iOS'
4. Build the project.
5. Search for 'pngcrush' in Build output.

Actual result: 'pngcrush' does not appear in Build output.

Note: Using XS on Mac we are getting 'pngsrush' in build output.

Expected Result: 'pngcrush' should appear in build output.

Supplement info:
http://screencast.com/t/bPfeo3SYIbv3

Environment details:
All Windows
VS 2013/2012
Xamarin for VS 1.12.217

Regression Status:
NOT A REGRESSION: Same behavior happening with stable MTVS 1.10.39
Comment 1 Enzo Heredia 2015-07-03 11:06:54 UTC
not reproducible in 4.0.0.386
Comment 2 Akhilesh kumar 2015-07-06 11:54:31 UTC
I have checked this issue with latest XVS 4.0.0.389 and I am also not able to reproduce this issue with *Diagnostic* Build Output. After enabling  *Diagnostic* Build, on building iOS application with 'Optimize PNG images file for iOS', I am getting 'pngcrush' in Build output.

Screencast: http://screencast.com/t/LnpYA9tBLQo

Hence closing this issue.

Xamarin.VisualStudio_4.0.0.389_c31f65f628e85a0a9eddc890811bbbf7bd2c017f

Microsoft Visual Studio Ultimate 2013
Version 12.0.31101.00 Update 4
Microsoft .NET Framework
Version 4.6.00080