Bug 17871 - DateTimeFormatInfo.CurrentInfo defaults to US when device is set to UK
Summary: DateTimeFormatInfo.CurrentInfo defaults to US when device is set to UK
Status: RESOLVED DUPLICATE of bug 17151
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll ()
Version: 7.0.6.x
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Marek Safar
URL: http://forums.xamarin.com/discussion/...
Depends on:
Blocks:
 
Reported: 2014-02-19 07:39 UTC by John Hair
Modified: 2014-02-20 13:01 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 17151

Description John Hair 2014-02-19 07:39:13 UTC
Since updating to Mono3 and Xcode 5, Ive noticed this value defaults to what appears to be US settings. I noticed this because FirstDayOfWeek is Sunday. In the UK it should be Monday and before updating it was correct. I wouldn't know if this is a bug with Mono3, or Xamarin.iOS. But at least you guys can take a look and figure it out.

Regards
John
Comment 1 Marek Safar 2014-02-19 10:09:10 UTC
I need some way to reproduce the issue reliably.

Simple

			var ci = new CultureInfo ("en-GB");
			Console.WriteLine (ci.DateTimeFormat.FirstDayOfWeek);

works as expected
Comment 2 John Hair 2014-02-19 10:15:44 UTC
Try setting the device to be based in the UK. Then:

Console.WriteLine (DateTimeFormatInfo.CurrentInfo.FirstDayOfWeek);

Returns Sunday. Should by Monday.
Comment 3 John Hair 2014-02-19 10:28:43 UTC
Happy to demonstrate over Skype with 2 separate devices (iPhone 5s and iPad Mini 2)
Comment 4 John Hair 2014-02-19 10:34:57 UTC
Just tried with a new single view app, has the same issue.
Comment 5 Marek Safar 2014-02-19 12:41:39 UTC
This works as expected with master version of Xamarin.iOS and International Region Format set to United Kingdom
Comment 6 John Hair 2014-02-19 14:20:01 UTC
Ah, what?
Closed without even taking a look over Skype? I can replicate this 100% using current stable.
Poor showing guys. Not good enough. Contact me tmw to login over Skype or I'll escalate this.
Comment 7 John Hair 2014-02-20 10:21:40 UTC
https://bugzilla.xamarin.com/show_bug.cgi?id=17151

A user posted the link to the above bug, which looks like you fixed in master, you couldn't have mentioned that??

Can you at least tell me when this will be in stable?
Comment 8 Marek Safar 2014-02-20 13:01:18 UTC
This should be available next release after 7.1 (read as nothing imminent)

*** This bug has been marked as a duplicate of bug 17151 ***