Bug 17841 - throws error "System.Runtime.InteropServices.COMException (0x80070032)"
Summary: throws error "System.Runtime.InteropServices.COMException (0x80070032)"
Status: RESOLVED DUPLICATE of bug 11207
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: ASP.Net ()
Version: 4.2.3
Hardware: PC Windows
: --- normal
Target Milestone: master
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-02-18 08:30 UTC by derek.takamine
Modified: 2014-02-18 11:27 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 11207

Description derek.takamine 2014-02-18 08:30:16 UTC
When I try to create a c# / ASP.NET / Web Application, I immediately get the following error:

System.Exception: System.Web assembly name not found for framework .NETFramework,Version=v4.0
   at MonoDevelop.AspNet.WebTypeContext.GetSystemWebDom(TargetRuntime runtime, TargetFramework targetFramework)
   at MonoDevelop.AspNet.WebTypeContext.GetSystemWebDom(AspNetAppProject project)
   at MonoDevelop.AspNet.WebTypeContext..ctor(AspNetAppProject project)
   at MonoDevelop.AspNet.Parser.DocumentReferenceManager..ctor(AspNetAppProject project)
   at MonoDevelop.AspNet.Gui.AspNetEditorExtension.OnParsedDocumentUpdated()
   at MonoDevelop.XmlEditor.Gui.BaseXmlEditorExtension.<Initialize>b__0(Object param0, EventArgs param1)
   at System.EventHandler.Invoke(Object sender, EventArgs e)
   at MonoDevelop.Ide.Gui.Document.OnDocumentParsed(EventArgs e)
   at MonoDevelop.Ide.Gui.Document.<>c__DisplayClass20.<>c__DisplayClass22.<>c__DisplayClass24.<StartReparseThread>b__1f(Object param0, EventArgs param1)
   at Gtk.Application.InvokeCB.Invoke()
   at GLib.Timeout.TimeoutProxy.Handler()




When I try to run the code I get the following error:

	System.Runtime.InteropServices.COMException (0x80070032): The request is not supported. (Exception from HRESULT: 0x80070032)
   at Microsoft.Samples.Debugging.CorDebug.NativeApi.ICorDebug.CreateProcess(String lpApplicationName, String lpCommandLine, SECURITY_ATTRIBUTES lpProcessAttributes, SECURITY_ATTRIBUTES lpThreadAttributes, Int32 bInheritHandles, UInt32 dwCreationFlags, IntPtr lpEnvironment, String lpCurrentDirectory, STARTUPINFO lpStartupInfo, PROCESS_INFORMATION lpProcessInformation, CorDebugCreateProcessFlags debuggingFlags, ICorDebugProcess& ppProcess)
   at Microsoft.Samples.Debugging.CorDebug.CorDebugger.CreateProcess(String applicationName, String commandLine, SECURITY_ATTRIBUTES processAttributes, SECURITY_ATTRIBUTES threadAttributes, Boolean inheritHandles, Int32 creationFlags, IntPtr environment, String currentDirectory, STARTUPINFO startupInfo, PROCESS_INFORMATION& processInformation, CorDebugCreateProcessFlags debuggingFlags)
   at Microsoft.Samples.Debugging.CorDebug.CorDebugger.CreateProcess(String applicationName, String commandLine, String currentDirectory, IDictionary`2 environment, Int32 flags)
   at MonoDevelop.Debugger.Win32.CorDebuggerSession.<>c__DisplayClass5.<OnRun>b__4()
   at MonoDevelop.Debugger.Win32.MtaThread.Run(Action ts)
   at MonoDevelop.Debugger.Win32.CorDebuggerSession.OnRun(DebuggerStartInfo startInfo)
   at Mono.Debugging.Client.DebuggerSession.<>c__DisplayClass10.<Run>b__e()
Comment 1 Mikayla Hutchinson [MSFT] 2014-02-18 11:27:11 UTC

*** This bug has been marked as a duplicate of bug 11207 ***