Bug 17787 - Custom components are not being rendered because problems were detected
Summary: Custom components are not being rendered because problems were detected
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS Designer ()
Version: 4.3.0
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: master
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-02-14 16:27 UTC by CraigD
Modified: 2014-02-17 02:38 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Log of designer errors (177.49 KB, application/octet-stream)
2014-02-14 16:27 UTC, CraigD
Details
Xamarin Studio showing designer error (178.45 KB, image/png)
2014-02-14 16:27 UTC, CraigD
Details
Xcode showing correct design surface (122.27 KB, image/png)
2014-02-14 16:27 UTC, CraigD
Details
iOS Todo app showing storyboard designer error (1.63 MB, application/x-zip-compressed)
2014-02-14 16:29 UTC, CraigD
Details
iOS app showing storyboard designer error (1.67 MB, application/x-zip-compressed)
2014-02-14 16:32 UTC, CraigD
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description CraigD 2014-02-14 16:27:08 UTC
Created attachment 6054 [details]
Log of designer errors

Xamarin Studio 4.3.2 (build 2) in the alpha channel

There are no 'custom components' in this project -- it is unable to render 'static' cells in a UITableViewController. Screenshots of Xamarin Studio and Xcode are attached (as well as the log and source project).

For some reason it also isn't rendering the segue between view controllers.
Comment 1 CraigD 2014-02-14 16:27:38 UTC
Created attachment 6055 [details]
Xamarin Studio showing designer error
Comment 2 CraigD 2014-02-14 16:27:59 UTC
Created attachment 6056 [details]
Xcode showing correct design surface
Comment 3 CraigD 2014-02-14 16:29:26 UTC
Created attachment 6057 [details]
iOS Todo app showing storyboard designer error
Comment 4 CraigD 2014-02-14 16:32:47 UTC
Created attachment 6058 [details]
iOS app showing storyboard designer error
Comment 5 Alan McGovern 2014-02-17 02:38:17 UTC
Firstly, this renders just fine with the latest builds: http://screencast.com/t/qBGweTpxdP5 . I presume that either 4.2.4 will fix whatever the issue was or the next 4.3.x alpha will fix if. If it's not fixed in 4.2.4 let me know and we will look into cherry-picking back whatever the fix is.

There was a known issue whereby rendering would fail sometimes due to a bug in Mono which we thought we had worked around, but we had actually missed one place where it still affected us.

Secondly, the iOS Designer uses 'custom components' to describe every UIView or UIViewController which is exported as a C# class. With that in mind, both TodoListViewContoller and TodoViewController are both custom components.