Bug 17681 - Application get crashed on x86 emulator when breakpoint gets hit
Summary: Application get crashed on x86 emulator when breakpoint gets hit
Status: RESOLVED DUPLICATE of bug 17410
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: 4.12.0
Hardware: PC Windows
: High critical
Target Milestone: 4.12.0 (KitKat)
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2014-02-10 04:59 UTC by narayanp
Modified: 2014-02-24 10:36 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 17410

Description narayanp 2014-02-10 04:59:26 UTC
Steps to reproduce:
1. Open or create android application.
2. Set breakpoint.
3. Debug the application.

Actual result: As soon as breakpoint gets hit, application get crashed on x86 emulator. While on other emulators and physical device this is working fine.

Expected result: Application should not crash.

Supplement info:
Android Log: https://gist.github.com/saurabh360/ba497b0759417bb30385
Adb Logcat: https://gist.github.com/saurabh360/927f0e92d2f74cd98de9
IDE Log: https://gist.github.com/saurabh360/d198d78264faf8ea9a4a

Environment details:
All Windows
X.S 4.2.4(build 14)
X.Android 4.12.0.22


Regression status: This is working fine with X.S 4.2.3(build 54)
Comment 2 Prashant manu 2014-02-11 05:03:11 UTC
An update to Comment#0

I have observed both Issues on different environments:

Windows 8.1
Facing Bug 17681 on all x86 emulators. This is the git of this environment details: https://gist.github.com/saurabh360/9cb27446df4c5c055d78

Mac Lion
Facing Bug 17681 on all x86 emulators. This is the git of this environment details: https://gist.github.com/saurabh360/da62858f04ef89d8c436

Windows 8.1
Facing Bug 17681 on API18 x86 emulator only. This is the git of this environment details: https://gist.github.com/AkhileshKumar01/5ea62a8ea0e8ac8e3777

Mac Maverick 10.9.2
Facing Bug 17410 on all x86 emulators. This is the gist of this environment details: https://gist.github.com/atin360/ba8a65e5c3344c338abf

Windows 7
Facing Bug 17681 on all x86 emulators. This is the git of this environment details: https://gist.github.com/saurabh360/14e98b9c3cb72577c748

Mac Mountain Lion 10.8.5
Facing Bug 17410 on all x86 emulators. This is the gist of this environment details: https://gist.github.com/saurabh360/fbc1bf1263acbfb55cf3

Windows 8
Facing Bug 17681 on all x86 emulators. This is the git of this environment details: https://gist.github.com/saurabh360/85b628793536c683df64

Mac Mountain Lion 10.8.5
Facing Bug 17410 on all x86 emulators. This is the gist of this environment details: https://gist.github.com/saurabh360/110f887068cf980d65ac

Windows 7
Facing Bug 17681 on all x86 emulators. This is the git of this environment details: https://gist.github.com/AkhileshKumar01/553b185d0bf004c6230f

Also both issues are Regression with stable X.Android 4.10.1-68 and X.Android 4.10.1-73
Comment 3 PJ 2014-02-24 10:36:20 UTC

*** This bug has been marked as a duplicate of bug 17410 ***