Bug 17602 - MD ignores project changes on build
Summary: MD ignores project changes on build
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: Trunk
Hardware: PC Windows
: Normal normal
Target Milestone: 4.2.4 (from master)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-02-05 00:26 UTC by Lopatkin Ilja
Modified: 2014-02-17 03:03 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Demonstration of the problem (3.78 MB, application/octet-stream)
2014-02-05 22:47 UTC, Lopatkin Ilja
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Lopatkin Ilja 2014-02-05 00:26:28 UTC
After recent update from trunk MD started to ignore changes I made to projects.
For example, if I add new file it simply wouldn't be compiled. And if I remove or rename some files CSC would complain about missing files. The only way to fix it I've found so far is to restart MD.
If it's of any importance, I was unable to build "MonoDevelop.Projects.Formats.MSBuild.dotnet.v12.0" and I simply removed it from solution file. Our project is targeted for .NET 4.0 so I believe it should be using "MonoDevelop.Projects.Formats.MSBuild.v4.0".
Comment 1 narayanp 2014-02-05 08:40:16 UTC
Could you please provide us the screenshot for error/test sample for this?
Comment 2 Mikayla Hutchinson [MSFT] 2014-02-05 15:15:40 UTC
Removing the 12.0 builder is incorrect. The MSBuild version is not tied to the framework version. The MSBuild 12.0 engine is backwards compatible with MSBuild 4.0.

You probably need to install Microsoft Build Tools 2013:
http://monodevelop.com/Developers/Building_MonoDevelop#Prerequisites_and_Source
Comment 3 Lopatkin Ilja 2014-02-05 22:47:27 UTC
Created attachment 5985 [details]
Demonstration of the problem
Comment 4 Lopatkin Ilja 2014-02-05 22:49:50 UTC
Thanks for the link about build requirements - I was able to build 12.0 engine now. But the problem still remains. I've added a screencast showing what's going on. If any additional information is needed, please let me know.
Comment 5 Mikayla Hutchinson [MSFT] 2014-02-06 04:45:24 UTC
Yes, I could repro it. Should be fixed by https://github.com/mono/monodevelop/commit/301c8e280fda82e72b0531d1b7dbc5ad2a548673
Comment 6 Sadik Ali 2014-02-17 03:03:58 UTC
I have verified this on below environment:

Windows
Xamarin Studio 4.2.4 (build 17)
Build Information
Release ID: 402040017
Git revision: 00b6aafbd9d5b59499aa5f9e7ba274f55ed95d5d
Xamarin addins: 2debf1c1984b1d3d8312decda84dc966b7412433

I followed steps as mentioned in attached video and observed that MD is not ignored changes I made to projects.

Refer screen cast: http://www.screencast.com/t/UwrC0QaX