Bug 17591 - Runtime VTable issue
Summary: Runtime VTable issue
Status: RESOLVED FIXED
Alias: None
Product: Compilers
Classification: Mono
Component: C# ()
Version: 3.2.x
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2014-02-04 06:42 UTC by Grigory (Playtika)
Modified: 2014-02-04 07:02 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Grigory (Playtika) 2014-02-04 06:42:44 UTC
Call to "base." in async void method works incorrectly. 
Workaround is simply to remove "base.".

namespace VTable
{
    public class BaseClass
    {
        private object _syncRoot = new object();

        public void FooAsync()
        {
            _syncRoot.ToString();
        }
    }

    public class DerivedClass : BaseClass
    {
        public async void DoJob()
        {
            base.FooAsync();
        }
    }
}

Usage:
new DerivedClass().DoJob();
Comment 1 Marek Safar 2014-02-04 06:59:13 UTC
Could you better describe what means "works incorrectly" ?
Comment 2 Grigory (Playtika) 2014-02-04 07:00:36 UTC
The code that i've sent crashes :)
Comment 3 Marek Safar 2014-02-04 07:02:43 UTC
Already fixed in mono 3.2.7