Bug 17540 - Search in AXML files is not possible
Summary: Search in AXML files is not possible
Status: CONFIRMED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android Designer ()
Version: 1.10.x
Hardware: PC Mac OS
: Normal enhancement
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-01-31 14:29 UTC by René Ruppert
Modified: 2017-07-11 17:55 UTC (History)
10 users (show)

Tags: vs ac
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 17540 on Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.
Related Links:
Status:
CONFIRMED

Description René Ruppert 2014-01-31 14:29:44 UTC
Open an Android AXML file in the editor in VS.
Switch to source view.
Press CTRL+F to search for something in the current file.
Instead of quick search, the "find in files" dialog will open. There is no way to search just the AXML.
Comment 1 Nischal 2014-02-03 02:24:19 UTC
I have checked this issue with the following builds:
All windows
VS 2010/2012/2013
Xam.Android 4.10.01073

We are also getting same behavior as mentioned in the bug.Below is the screen-cast for the same:
http://screencast.com/t/Zuw5ojNLjF

Hence confirming this issue.
Comment 2 Kent Green [MSFT] 2017-07-07 23:09:38 UTC
I have tested and found that this issue *does not* occur in the current Alpha channel on Mac:

Visual Studio Community 2017 for Mac (Preview)
Version 7.1 Preview (7.1 build 583)

Xamarin.Android
Version: 7.3.1.2 (Visual Studio Community)
Comment 3 mostafa 2017-07-10 16:46:17 UTC
I can see that the problem is fixed now on latest stable windows version. So feel free to close the ticket.