Bug 1754 - Dock does not autohide properly
Summary: Dock does not autohide properly
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Docking ()
Version: Trunk
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-10-28 06:15 UTC by Mikayla Hutchinson [MSFT]
Modified: 2012-03-06 19:39 UTC (History)
2 users (show)

Tags: gtk
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Mikayla Hutchinson [MSFT] 2011-10-28 06:15:48 UTC
When a dock is auto-shown by a mouse hover, it often doesn't re-hide when the mouse moves away or even when the mouse clicks on another part of MD.

See http://screencast.com/t/N2sgypIw
Comment 1 Mikayla Hutchinson [MSFT] 2011-10-28 07:00:18 UTC
This appears to be a GTK+ mac bug. 

If the mouse enters from outside the window, there's no leave event: http://screencast.com/t/Yaycsacs
Comment 2 Mikayla Hutchinson [MSFT] 2011-10-28 07:09:09 UTC
It's worse than I thought. We get the enter event for the first widget, but no leave event, and don't get any enter/leave events after that until the mouse is clicked.

http://screencast.com/t/PIWTzlxfyy
Comment 3 Mikayla Hutchinson [MSFT] 2011-11-07 11:03:09 UTC
This appears to be fixed by the patch in #546.
Comment 4 Mikayla Hutchinson [MSFT] 2012-03-06 19:39:29 UTC
Closing, since it hasn't been reported since that fix.