Bug 17478 - File New Xamarin.Mac project hangs while debugging
Summary: File New Xamarin.Mac project hangs while debugging
Status: VERIFIED FIXED
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Other ()
Version: 1.6.19
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Aaron Bockover [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2014-01-28 20:22 UTC by Redth
Modified: 2015-01-19 13:39 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Console IDE Log (9.51 KB, application/octet-stream)
2014-01-28 20:22 UTC, Redth
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Redth 2014-01-28 20:22:42 UTC
Created attachment 5929 [details]
Console IDE Log

Just tried creating a new Xamarin.Mac project (the "Xamarin.Mac Project" template with the Window and Window controller templates created), and without even making any changes, just running in Debug mode, the app compiles, and launches, but hangs (bouncing dock icon)...  Eventually you have to either stop debugging or force quit to end the process...

Here's my version info, and attached is my Console output....  

Xamarin Studio
Version 4.3.1 (build 5)
Installation UUID: e3cd7477-fd41-4f66-9f64-eb7f4eccf552
Runtime:
	Mono 3.2.6 ((no/9b58377)
	GTK+ 2.24.23 theme: Raleigh
	GTK# (2.12.0.0)
	Package version: 302060000

Apple Developer Tools
Xcode 5.0.2 (3335.32)
Build 5A3005

Xamarin.iOS
Version: 7.0.6.168 (Enterprise Edition)
Hash: 2ed9bc9
Branch: 
Build date: 2014-21-01 06:33:05-0500

Xamarin.Android
Version: 4.12.0 (Enterprise Edition)
Android SDK: /Users/jonathan/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
		4.4   (API level 19)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

Xamarin.Mac
Xamarin.Mac: 1.6.34

Build Information
Release ID: 403010005
Git revision: c8e0387a36f22ec945cfdeddbe56a9c61594746c
Build date: 2014-01-17 23:40:42+0000
Xamarin addins: 522675b4b87feda7438d2ac402234f9a4b8053e4

Operating System
Mac OS X 10.9.1
Darwin jonathans-mbp 13.0.0 Darwin Kernel Version 13.0.0
    Thu Sep 19 22:22:27 PDT 2013
    root:xnu-2422.1.72~6/RELEASE_X86_64 x86_64
Comment 1 Parmendra Kumar 2014-08-07 06:50:10 UTC
I have tried to reproduce this issue, It's working fine with latest stable build.So Please update to the latest stable build.
Please let us know if you face same issue in latest stable build.

Environment info:

=== Xamarin Studio ===

Version 5.2 (build 386)
Installation UUID: 67eaf3b4-f8a7-4ab4-a9df-3197350ca5dc
Runtime:
 Mono 3.6.0 ((no/f540f8a)
 GTK+ 2.24.23 (Raleigh theme)

 Package version: 306000039

=== Apple Developer Tools ===

Xcode 6.0 (6244.6)
Build 6A267n

=== Xamarin.iOS ===

Version: 7.2.6.28 (Business Edition)
Hash: 606f31a
Branch: 
Build date: 2014-08-01 15:27:48-0400

=== Xamarin.Android ===

Version: 4.14.0 (Business Edition)
Android SDK: /Users/ixamarin78/Desktop/android-sdk-macosx
 Supported Android versions:
  2.1   (API level 7)
  2.2   (API level 8)
  2.3   (API level 10)
  3.1   (API level 12)
  3.2   (API level 13)
  4.0   (API level 14)
  4.0.3 (API level 15)
  4.1   (API level 16)
  4.2   (API level 17)
  4.3   (API level 18)
  4.4   (API level 19)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

=== Xamarin.Mac ===

Version:  1.8.1.6 (Business Edition)

=== Build Information ===

Release ID: 502000386
Git revision: e6a54dee5376e6e7a2d9982695b060fddc09e65d
Build date: 2014-08-04 14:03:28-04
Xamarin addins: 2b5a5c26ac2ee74c6e91a8d24ef44d0ca9cb74d0

=== Operating System ===

Mac OS X 10.9.4
Darwin XamnewiMac.local 13.3.0 Darwin Kernel Version 13.3.0
    Tue Jun  3 21:27:35 PDT 2014
    root:xnu-2422.110.17~1/RELEASE_X86_64 x86_64
Comment 2 Timothy Risi 2015-01-16 17:19:27 UTC
Tested and working correctly
Comment 3 Parmendra Kumar 2015-01-19 13:39:25 UTC
As per comment #2, I am closing this issue. If you getting same behavior please reopen the bug.