Bug 17386 - (401) Unauthorized when attempting to activate
Summary: (401) Unauthorized when attempting to activate
Status: RESOLVED INVALID
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: 1.8.x
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: dean.ellis
URL:
Depends on:
Blocks:
 
Reported: 2014-01-22 19:55 UTC by Allie Miller
Modified: 2014-01-30 10:41 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Screen shots of errors (170.35 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-01-23 17:09 UTC, sergio.sermeno
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description Allie Miller 2014-01-22 19:55:17 UTC
In Visual Studio 2012, when a user attempts to activate they run into the following error: 

System.Net.WebException: The remote server returned an error: (401) Unauthorized.
at System.Net.HttpWebRequest.GetResponse()
at Xamarin.Components.Ide.Web.RequestHelper.GetResponse(Func`1 createRequest, Action`1 prepareRequest, CancellationToken token)
at Xamarin.Components.Ide.SSO.Client.DoRequest(String endpoint, String method, String body, CancellationToken cancellationToken)
at Xamarin.Components.Ide.SSO.Client.CreateToken(String email, String password, CancellationToken cancellationToken)
at Xamarin.Components.Ide.SSO.Client.<>c__DisplayClass5.<CreateTokenAsync>b__4()
at System.Threading.Tasks.Task`1.InnerInvoke()
at System.Threading.Tasks.Task.Execute()
Comment 1 sergio.sermeno 2014-01-23 17:09:17 UTC
Created attachment 5904 [details]
Screen shots of errors
Comment 2 dean.ellis 2014-01-29 10:10:27 UTC
Looking at the screen shots from the document, it looks to be a proxy server issue. The grey dialog that pops up looks like a proxy authentication dialog. This is not a dialog that the xamarin site would produce as far as I can tell. 

Are you running the software behind a proxy server?
Comment 3 Allie Miller 2014-01-30 10:41:24 UTC
It looks like this issue was due to the proxy server. The user had attempted to enter their own proxy credentials. Once the logging for the proxy processing any Xamarin.com, the activation occurred successfully.

Based on that, I'll close this bug :)