Bug 17367 - NullPointerException when building
Summary: NullPointerException when building
Status: RESOLVED INVALID
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: 4.3.x
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2014-01-22 08:45 UTC by Miha Valencic
Modified: 2017-06-28 19:35 UTC (History)
4 users (show)

Tags: bb
Is this bug a regression?: ---
Last known good build:


Attachments
Output from a build (57.38 KB, text/plain)
2014-01-22 08:45 UTC, Miha Valencic
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description Miha Valencic 2014-01-22 08:45:20 UTC
Created attachment 5887 [details]
Output from a build

When trying to build a MvvmCross example, I got two errors. One was that APK was too big (which I understand) and another was a NullPointerException. The build output is attached in the file:

:  monodroiderror XA0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. Reason: System.NullReferenceException: Object reference not set to an instance of an object
  Task "ScanAssemblies" execution -- FAILED
  Done building target "_ScanAssemblies" in project "/Users/miha/work/dev/xamarin/MvvmCross-Tutorials/Fragments/FragmentSample.UI.Droid/FragmentSample.UI.Droid.csproj".-- FAILED
Comment 1 Miha Valencic 2014-01-22 08:45:50 UTC
Note that the second build (after activating trial) succeeded.
Comment 2 Jonathan Pryor 2014-01-22 10:42:19 UTC
Which MvvmCross sample is this?
Comment 3 Miha Valencic 2014-01-22 10:54:54 UTC
It is Fragments: https://github.com/MvvmCross/MvvmCross-Tutorials/tree/master/Fragments

I'm guessing it is not related to MvvmCross, but to the way XamarinStudio handles the "free version" constraint. I believe the "root" cause of the error is large apk and a version of XS that does not support this (i.e. the free version). After I upgraded to Business Edition (trial) it went through.
Comment 4 Tom Opgenorth 2017-06-28 19:21:35 UTC
Thank you for taking the time to submit the bug. We are unable to reproduce this issue. Please attach a reproduction to the bug by starting with a clean Xamarin.Android project and adding just the code necessary to demonstrate the issue.
Comment 5 Miha Valencic 2017-06-28 19:35:31 UTC
It is been more than 3 years so... impossible to reproduce now.