Bug 17364 - [Already done?] "devenv.exe /setup" needn't be run for all installed versions of devenv.exe
Summary: [Already done?] "devenv.exe /setup" needn't be run for all installed versions...
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Installer ()
Version: 1.10.x
Hardware: PC Mac OS
: --- enhancement
Target Milestone: ---
Assignee: Marek Habersack
URL:
Depends on:
Blocks:
 
Reported: 2014-01-21 23:40 UTC by Brendan Zagaeski (Xamarin Team, assistant)
Modified: 2014-01-22 11:37 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Brendan Zagaeski (Xamarin Team, assistant) 2014-01-21 23:40:22 UTC
Reported on behalf of a user.

## Already fixed in master?

I believe this behavior is already fixed in the latest wrench builds of xamarinvs-master. In fact the whole installation procedure runs delightfully quickly in the version from master. Very nice!

I'll just file this bug for completeness, and to double-check that this is no longer an issue in xamarinvs-master.

Feel free to close this right away!


## Steps to reproduce

1. Boot a fresh Windows system that has at least two versions of Visual Studio installed.

2. Open the Task Manager, and sort the processes by name.

2. Run the Xamarin.Android installer.

3. On the "Custom Setup" screen, pick "Entire feature will be unavailable" for all but one of the installed VS versions. That is, leave only one "Xamarin for VS 201*" entry set to "Will be installed to local hard drive".

4. Proceed to install Xamarin.Android.


## Result

Near the end of the installation procedure, each of the installed versions of `devenv.exe` can be observed to run for a while in the Task Manager.


## Expected result

Only the `devenv.exe` corresponding to the "Xamarin for VS" version that was marked "Will be installed to local hard drive" needs to run.
Comment 1 Marek Habersack 2014-01-22 04:30:53 UTC
It is indeed fixed in master and will be part of the 1.12 release :)
Comment 2 Brendan Zagaeski (Xamarin Team, assistant) 2014-01-22 11:37:34 UTC
Awesome, thanks!