Bug 17349 - 'MinimumOSVersion does not include the device version' error should appear in error list not just output.
Summary: 'MinimumOSVersion does not include the device version' error should appear in...
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 0.x Insider Preview
Hardware: PC Windows
: --- normal
Target Milestone: 1.12 (Merge)
Assignee: Jose Miguel Torres
URL:
Depends on:
Blocks:
 
Reported: 2014-01-21 10:41 UTC by PJ
Modified: 2014-02-03 06:10 UTC (History)
4 users (show)

Tags: error improvement
Is this bug a regression?: ---
Last known good build:


Attachments
Screenshot on MTXXXX handling (42.42 KB, image/png)
2014-01-30 10:33 UTC, Jose Miguel Torres
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description PJ 2014-01-21 10:41:12 UTC
Steps to reproduce:

1) Try to deploy to a 6.0 device while your deployment target is 7.0

Expected:

Error appears in error list

Actual:

Error just shows in the Output. User must comb the log to see the error. See http://screencast.com/t/kP6z3MU3q


Reported against:
MTVS 1.10.39
Comment 1 Jose Miguel Torres 2014-01-29 07:22:07 UTC
Actually I think we should go one step forward on this and let VS decide whether the project could be deployed or no depending on the iOS Device OSVersion.

So, technically we should hand the OSVersion on mtbserver and propagate it to VS inside LIstDeviceCommand. 

Does it make sense Pj?
Comment 2 Jose Miguel Torres 2014-01-29 07:23:18 UTC
Actually I have just realized, this is a feature disparity with XS. Hence this should be discussed and scheduled with Dominique.
Comment 6 Jose Miguel Torres 2014-01-30 10:33:54 UTC
Created attachment 5946 [details]
Screenshot on MTXXXX handling

I have check this issue with MTVS 1.12.186 on VS2012 and it is handling this issue correctly. Not sure why it is happening on MTVS 1.10.x 

Investigating...
Comment 7 PJ 2014-01-30 16:05:11 UTC
Oh ok, great. If we already have the right behavior in 1.12 we can just close this issue and have it verified for the 1.12 release, I don't think we'll revisit this for 1.10.

Thanks for checking Jose!

PJ
Comment 8 Nischal 2014-02-03 06:10:58 UTC
I have validated this issue with the following builds:
VS 2013
iOS for VS 1.12.177

we are getting proper error information when Try to deploy to a 6.0 device while your deployment target is 7.0.Below is the screen-cast for the same:
http://screencast.com/t/EMlQbzQz3y

Hence verifying this issue.