Bug 17214 - Xamarin Shell disables Windows Phone Emulator "Resolution selector"
Summary: Xamarin Shell disables Windows Phone Emulator "Resolution selector"
Status: RESOLVED NORESPONSE
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General ()
Version: 1.10.x
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-01-13 22:25 UTC by Brendan Zagaeski (Xamarin Team, assistant)
Modified: 2015-08-05 09:24 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Brendan Zagaeski (Xamarin Team, assistant) 2014-01-13 22:25:00 UTC
Reported from the forums:
http://forums.xamarin.com/discussion/11825/xamarin-android-disables-windows-phone-emulator-resolution-selector-vs2013

## Problem
"Usually the Start Debugging button in VS2013 gives a choice which resolution the Windows Phone 8 emulator image should use. After installing Xamarin for Android (Stable) this choice is gone and I could not select the destination device. After removing the Xamarin.Core component (Tools/Extensions) everything was fine again.

Seems the Xamarin.Core overwrites some Toolbar behaviours - even in WP8 projects."


## Workaround
"I found that if you run the emulator from the command line (xde.exe) while Visual Studio is running, that all of the installed emulator versions will show up as they are supposed to in VS. At that point you can close the version you started manually and everything will work as expected (VS will show the emulator list and launch into the one you specify)."
Comment 1 dean.ellis 2014-01-14 05:07:00 UTC
I have not seen this in VS2012 or VS2013, I have both addin's installed and am able to see the WP8 emulators in the drop down off the start button. But only when the WP8 project is set as startup.
Comment 2 dean.ellis 2014-01-14 05:09:49 UTC
Which version of the extension are they using? The forum post was posted in december which means it probably occurred in the MTVS 1.8 release which had known problems with VS2013.
Comment 4 Brendan Zagaeski (Xamarin Team, assistant) 2014-01-14 14:16:02 UTC
Thanks for checking this out! I added a post on the forums, suggesting that those folks try version 1.10 if they haven't already.
Comment 5 Udham Singh 2015-08-05 09:24:41 UTC
As there is no response from 01-14-2014 so I am closing this issue. Marking As RESOLVED-NORESPONSE. Please feel free to reopen this issue if you are still getting this issue.

Thanks!