Bug 1720 - Right edge of selection is fuzzy
Summary: Right edge of selection is fuzzy
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 2.8
Hardware: PC Mac OS
: --- minor
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2011-10-27 09:11 UTC by Mikayla Hutchinson [MSFT]
Modified: 2011-12-09 07:25 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Shows fuzzy edge with a normal selection. (14.60 KB, image/png)
2011-10-27 09:11 UTC, Mikayla Hutchinson [MSFT]
Details
Shows fuzzy edge with multiline col selection (23.60 KB, image/png)
2011-10-27 09:12 UTC, Mikayla Hutchinson [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Mikayla Hutchinson [MSFT] 2011-10-27 09:11:22 UTC
Created attachment 778 [details]
Shows fuzzy edge with a normal selection.

The right edge of the selection is fuzzy. See attached screenshots. Probably a cairo  0.5px issue.
Comment 1 Mikayla Hutchinson [MSFT] 2011-10-27 09:12:43 UTC
Created attachment 779 [details]
Shows fuzzy edge with multiline col selection
Comment 2 Mike Krüger 2011-10-28 00:57:02 UTC
Couldn't repro that - but maybe it has to do with some settings or drivers.
However I've fixed one 0.5px issue (which seems not to change anything for me).

If the rendering is still wrong, re-open the bug.
Comment 3 Mikayla Hutchinson [MSFT] 2011-11-23 16:09:55 UTC
This is still an issue when the column ruler is enabled.
Comment 4 Mikayla Hutchinson [MSFT] 2011-11-23 16:10:21 UTC
(It's fine when the column ruler is disabled)
Comment 5 Mikayla Hutchinson [MSFT] 2011-11-28 14:07:13 UTC
With the latest fix, it's no longer fuzzy, but in some cases there it jitter: http://screencast.com/t/6Xb5SsDrpE
Comment 6 Mike Krüger 2011-12-09 07:25:01 UTC
fixed that one ... again