Bug 17134 - Profiles / identities not showing up in Visual Studio
Summary: Profiles / identities not showing up in Visual Studio
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 1.8.x
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Dominique Louis
URL:
Depends on:
Blocks:
 
Reported: 2014-01-08 20:55 UTC by Jon Goldberger [MSFT]
Modified: 2015-01-05 11:19 UTC (History)
11 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
mtbserver logs (72.25 KB, text/plain)
2014-01-08 21:04 UTC, Jon Goldberger [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Comment 1 Jon Goldberger [MSFT] 2014-01-08 21:01:22 UTC
From the case file:
"I’m not having any luck getting the provisioning profiles to show up in Visual Studio. I have gone through the process several times to generate/download a certificate, then create/download a provisioning profile. They show up in XCode Organizer but not in VS Bundle Signing. When I go back to the Apple portal the status of the provisioning portals is changing to Invalid. Perhaps it is because of my multiple attempts…."

-------------------------------------------
Version info

=== Xamarin Studio ===

Version 4.2.2 (build 2)
Installation UUID: 0f14cdd4-0829-491d-b6ae-89dba54c7037
Runtime:
Mono 3.2.5 ((no/964e8f0)
GTK+ 2.24.20 theme: Raleigh
GTK# (2.12.0.0)
Package version: 302050000

=== Apple Developer Tools ===

Xcode 5.0.2 (3335.32)
Build 5A3005

=== Xamarin.iOS ===

Version: 7.0.4.209 (Business Edition)
Hash: 23a0827
Branch:
Build date: 2013-11-11 16:04:00-0500

=== Xamarin.Mac ===

Xamarin.Mac: Not Installed

=== Xamarin.Android ===

Version: 4.10.1 (Starter Edition)
Android SDK: /Users/tony/Library/Developer/Xamarin/android-sdk-mac_x86
Supported Android versions:
2.1 (API level 7)
2.2 (API level 8)
2.3 (API level 10)
3.1 (API level 12)
4.0 (API level 14)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

=== Build Information ===

Release ID: 402020002
Git revision: c5f82958ae7d9af652b44b87ceff777b3ad19b91
Build date: 2013-11-19 15:35:40+0000
Xamarin addins: a4044fee09138f6fd031a9944b7caaeb51e57e80

=== Operating System ===

Mac OS X 10.9.1
Darwin Tonys-MacBook-Air.local 13.0.0 Darwin Kernel Version 13.0.0
Thu Sep 19 22:22:27 PDT 2013
root:xnu-2422.1.72~6/RELEASE_X86_64 x86_64
Comment 2 Jon Goldberger [MSFT] 2014-01-08 21:04:20 UTC
Created attachment 5800 [details]
mtbserver logs

both mtbserver.log and mtbservergui.log are included
Comment 4 Jon Goldberger [MSFT] 2014-01-09 13:57:18 UTC
The client reports that they are now able to see their profiles in Visual Studio. 

They sent this message:
"Well, after a week of pulling my hair out I finally have the provisioning profiles working. I’m not sure exactly what fixed it but I have a hunch it was going into Xamarin Studio on the Mac, then to Preferences -> Developer Accounts -> View Details, where the new profiles eventually come in if you wait for a little while. When I went back to VS they were there also.

I also had created a new app in Xcode and now open Organizer from there, which got rid of all the remnants of old profiles that no longer exist.

This whole process could definitely be improved and explained better, but I’m OK for now. "
Comment 5 Saurabh 2014-10-30 04:06:48 UTC
I have also checked this at my end I am also able to use newly created provisioning profile in VS.

As per Comment#4
Changing the status to Resolved/Fixed