Bug 17065 - iOS build in Visual Studio gets stuck and cannot be aborted if build host was not found
Summary: iOS build in Visual Studio gets stuck and cannot be aborted if build host was...
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 1.10.x
Hardware: PC Mac OS
: Normal normal
Target Milestone: 1.12 (Merge)
Assignee: dean.ellis
URL:
Depends on:
Blocks:
 
Reported: 2014-01-06 04:21 UTC by René Ruppert
Modified: 2014-02-04 03:53 UTC (History)
8 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description René Ruppert 2014-01-06 04:21:12 UTC
I'm running Parallels 9 with Windows 8.1 and Visual Studio 2013 on Mavericks.
I have installed the VS adding from the beta channel.
If I wake up my machine and start the first build of my iOS project (F5), I get an error that the build host was not configured. I double click the error and connect to the build host.
The error message disappears, however the build won't continue.
I cannot cancel or abort the build. The only thing that helps is to kill VS from the task manager.

If I try to cancel I get an info message that deployment to the Simulator cannot be interrupted. The build output shows:

------ Build started: Project: TestClient_iOS, Configuration: Debug iPhoneSimulator ------
C:\Users\rene\Documents\Visual Studio 2013\Projects\Test\Test  Development\Test.Clients.Mobile\packages\Microsoft.Bcl.Build.1.0.13\tools\Microsoft.Bcl.Build.targets(225,5): warning : All projects referencing TestClient_Core.csproj must install nuget package Microsoft.Bcl.Build. For more information, see http://go.microsoft.com/fwlink/?LinkID=317569.
  Consider app.config remapping of assembly "System.Threading.Tasks, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" from Version "1.5.11.0" [] to Version "4.0.0.0" [C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoTouch\v1.0\Facades\System.Threading.Tasks.dll] to solve conflict and get rid of warning.
  Consider app.config remapping of assembly "System.Runtime, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" from Version "2.6.6.0" [] to Version "4.0.0.0" [C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoTouch\v1.0\Facades\System.Runtime.dll] to solve conflict and get rid of warning.
  Consider app.config remapping of assembly "System.IO, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" from Version "1.5.11.0" [] to Version "4.0.0.0" [C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoTouch\v1.0\Facades\System.IO.dll] to solve conflict and get rid of warning.
  Consider app.config remapping of assembly "System.Net.Http, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" from Version "1.5.0.0" [C:\Users\rene\Documents\Visual Studio 2013\Projects\Test\Test  Development\Test.Clients.Mobile\TestClient_Core\bin\Debug\System.Net.Http.dll] to Version "2.0.5.0" [C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoTouch\v1.0\System.Net.Http.dll] to solve conflict and get rid of warning.
C:\Program Files (x86)\MSBuild\12.0\bin\Microsoft.Common.CurrentVersion.targets(1635,5): warning MSB3276: Found conflicts between different versions of the same dependent assembly. Please set the "AutoGenerateBindingRedirects" property to true in the project file. For more information, see http://go.microsoft.com/fwlink/?LinkId=294190.
  TestClient_iOS -> C:\Users\rene\Documents\Visual Studio 2013\Projects\Test\Test  Development\Test.Clients.Mobile\TestClient_iOS\bin\iPhoneSimulator\Debug\TestClient_iOS.exe



The last thing shown in the build host log:

[06-Jan-2014 10:12:22] Command [Info: CommmandUrl=Info] finished (10)
[06-Jan-2014 10:12:23] Handling with command: [StatusSdk: CommmandUrl=StatusSdk] (11)
[06-Jan-2014 10:12:23] Attempting to acquire command execution lock, timeout set to 00:10:00
[06-Jan-2014 10:12:27] Handling with command: [ListDevices: CommmandUrl=ListDevices] (12)
[06-Jan-2014 10:12:27] Attempting to acquire command execution lock, timeout set to 00:10:00
[06-Jan-2014 10:12:27] Command [ListDevices: CommmandUrl=ListDevices] finished (12)
[06-Jan-2014 10:12:59] Command [StatusSdk: CommmandUrl=StatusSdk] finished (11)
Comment 1 dean.ellis 2014-01-27 04:06:43 UTC
Fixed in XamarinVS/master/6a0c18fde4
Comment 2 René Ruppert 2014-02-03 03:58:05 UTC
I'm running the current beta 1.10.39 of the VS plugin and the issue still exists. Is it supposed to be fixed in there?
Comment 3 narayanp 2014-02-04 02:53:18 UTC
I have checked this issue with following builds:

Windows 8.1
VS 2013
MTVS 1.12.207
Maverick 10.9.2
X.iOS 7.1.4.3

to reproduce this issue I have connected VS 2013 to maverick and then after some time my machine was in Sleep mode. When I wake up my windows machine again and build the project. It builds successfully without giving any connection error.
Comment 4 René Ruppert 2014-02-04 03:35:54 UTC
But 1.12 is not available yet, correct?
Comment 5 dean.ellis 2014-02-04 03:53:02 UTC
1.12 is not available yet, it should appear in the alpha channel soon (its going though QA at the moment)