Bug 17013 - Windows.forms edit box not working on raspbian.
Summary: Windows.forms edit box not working on raspbian.
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: Windows.Forms ()
Version: unspecified
Hardware: Other Linux
: Lowest normal
Target Milestone: Untriaged
Assignee: Alex Rønne Petersen
URL:
Depends on:
Blocks:
 
Reported: 2014-01-01 15:33 UTC by Peter Michael Green
Modified: 2015-10-28 05:31 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
A (potential) CLI test case for the error using a RichTextBox in a console app (24.67 KB, application/x-zip-compressed)
2014-04-01 10:31 UTC, Kirill
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Peter Michael Green 2014-01-01 15:33:53 UTC

    
Comment 1 Peter Michael Green 2014-01-01 15:35:54 UTC
Note: this was originally posted as a comment on https://bugzilla.xamarin.com/show_bug.cgi?id=7938 but alexrp asked me to file it as a seperate bug.

I maintain a Debian derivative called Raspbian which aims to supply a hard
float system for the raspberry pi (and in principle other armv6 devices but in
practice the Pi is the only armv6 device anyone seems to care about).

Directhex pulled the armhf stuff into the 3.2 packages in debian experimental
and I in turn pulled those packages into raspbian wheezy and jessie.

The new version is MUCH better than what we had before but unfortunately it
seems to crash when using the windows.forms edit box. The original user report
(including a testcase) can be found at
http://www.raspberrypi.org/forum/viewtopic.php?f=66&t=11634&p=478459#p477499

Directhex thinks this may be related to the homogeneous aggregates issue.
Comment 2 Miguel de Icaza [MSFT] 2014-02-12 17:27:05 UTC
Setting priority to lowest, since Windows.Forms is no longer being developed actively.
Comment 3 kerschl.alexander 2014-02-13 01:28:16 UTC
We are just looking for a easy to use GUI Framework for an embedded system which is based on Linux. We would like to use MONO, because of our C# background. Designer support is a must (similar to WinForms)

If Windows.Forms is not recommended, what is the preferred GUI technology to use with MONO?
Comment 4 Mikayla Hutchinson [MSFT] 2014-02-13 13:20:19 UTC
GTK# is your best option for a UI toolkit with Mono on Linux.
Comment 5 Alex Rønne Petersen 2014-02-17 07:03:01 UTC
Note that this bug is not directly related to WinForms, it just happens to manifest there. It's really because we don't handle floating point aggregates on armhf yet.

Admittedly, I would prefer a repro that doesn't use WinForms since I have no monitors connected to my ARM boards...
Comment 6 Kirill 2014-04-01 10:31:17 UTC
Created attachment 6446 [details]
A (potential) CLI test case for the error using a RichTextBox in a console app

Here's a test case that uses a RichTextBox from a console application so you should be able to use that without using a Monitor. The ZIP contains a compiled binary and a VisualStudio Project around it.
Comment 7 tzjc 2014-04-03 02:55:59 UTC
Experiencing the same issue on a raspberry when running winforms based app, mono crashes upon drawing textbox.
Comment 8 Alex Rønne Petersen 2015-05-07 20:12:26 UTC
Zoltan has implemented the last bits of armhf ABI support on master. Can you try on Mono master and see if it works?
Comment 9 Alex Rønne Petersen 2015-10-28 05:31:26 UTC
Since our armhf support is complete and there's been no activity on this bug, I'm closing it as fixed. Feel free to reopen if this is still an issue.