Bug 17002 - Android project template is missing manifest settings
Summary: Android project template is missing manifest settings
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: 1.10.x
Hardware: PC Windows
: Highest normal
Target Milestone: ---
Assignee: dean.ellis
URL:
Depends on:
Blocks:
 
Reported: 2013-12-31 10:48 UTC by Mark Smith
Modified: 2014-04-18 11:56 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Mark Smith 2013-12-31 10:48:49 UTC
When creating a new Android project, the Android manifest options are not set - it is missing the application name, version and icon setting.  These are set to default values when creating the project with Xamarin Studio and should be set here as well.  In addition, the main Activity added has the Icon set on the ActivityAttribute in Visual Studio, but does not in Xamarin Studio - we should be consistent so I'm filing it here but it might require a change to the Xamarin Studio template for this.
Comment 2 dean.ellis 2014-01-16 05:29:12 UTC
Fixed in XamarinVs/master/f0b36d374a
Comment 3 Sunil Kumar 2014-03-26 11:34:04 UTC
I have checked this issue and getting the below observations:

1. When creating a new Android project in VS, the Android manifest options are getting display same as in XS.

Screencast of source: http://screencast.com/t/UI91j08cPhsR
Screencast of UI: http://screencast.com/t/5lKGaDge

2. Main Activity: Icon set is not getting displayed in Xamarin Studio. However,it's displaying in VS.

Screencast: http://screencast.com/t/WF7Hh7Cnc

Environment info:
VS 2012
Xamarin for VS 1.99.396.0(Master Build)

Second part of this issue still persist. so, I am reopening this issue for observation 2.
Comment 4 dean.ellis 2014-04-16 08:56:57 UTC
Sunil

Is this a bug for VS or XS? i.e should we remove the icon code in VS or add it in XS?

If its XS that needs to change we need to change the product and assign it to one of the XS team to fix.
Comment 5 Sunil Kumar 2014-04-18 11:56:35 UTC
observation 2: Main Activity: Icon set is not getting displayed in Xamarin Studio.
However,it's displaying in VS. This issue exist in XS. So I filed a new Bug 19163 for the same in XS product.

Hence. I am closing this issue.