Bug 1696 - Installation successful, program crashes immediately
Summary: Installation successful, program crashes immediately
Status: RESOLVED NORESPONSE
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools ()
Version: 5.0
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-10-26 12:50 UTC by kenny goers
Modified: 2013-12-05 18:35 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description kenny goers 2011-10-26 12:50:59 UTC
I get the following error on start up after a successful install, if I re-install problem goes away, can someone explain when the installation tool can't figure this out?

No log is left of the "crash".

Oct 26 12:47:05 unknown com.apple.launchd[1] <Error>: (UIKitApplication:com.cegedim.mi7[0x60dc]) posix_spawn("/var/mobile/Applications/1F5DBD59-8452-47AB-994B-61C24FC16D85/MI.app/MI", ...): Permission denied
Oct 26 12:47:05 unknown com.apple.launchd[1] <Warning>: (UIKitApplication:com.cegedim.mi7[0x60dc]) Exited with code: 1
Oct 26 12:47:05 unknown SpringBoard[15] <Warning>: Unable to obtain a task name port right for pid 649: (os/kern) failure
Oct 26 12:47:05 unknown com.apple.launchd[1] <Warning>: (UIKitApplication:com.cegedim.mi7[0x60dc]) Throttling respawn: Will start in 2147483647 seconds
Oct 26 12:47:05 unknown SpringBoard[15] <Warning>: Application 'MI7' exited abnormally with exit status 1
Comment 1 Sebastien Pouliot 2011-10-26 16:08:56 UTC
The "Permission denied" is likely the issue - but how this happened would be part of earlier log entries.

Unless we can have a test case to replicate this we will need to compare the upload/installation and execution logs for both a working and a failed case.

You can execute from a terminal window:

/Developer/MonoTouch/usr/bin/mtouch --logdev

Then 

* upload/install and execute a failed attempt, copy/paste the log and attach it

* upload/install and execute a successful attempt, copy/paste the log and attach it
Comment 2 PJ 2013-11-19 17:04:52 UTC
This bug has been in the NEEDINFO state with no changes for the last 90 days. Can we put this back into the NEW or CONFIRMED state, or are we still awaiting response?

If there is no change in the status of this bug over the next two weeks, this bug will be marked as NORESPONSE.
Comment 3 PJ 2013-12-05 18:35:05 UTC
This bug has not been changed from the NEEDINFO state since my previous comment, marking as RESOLVED NORESPONSE.

Please feel free to REOPEN this bug at any time if you are still experiencing the issue. Please add the requested information and set the bug back to the NEW (or CONFIRMED) state.