Bug 1692 - Changing process priority sometimes fails with "Process not found"
Summary: Changing process priority sometimes fails with "Process not found"
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: JIT ()
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-10-26 08:08 UTC by Kari Takanen
Modified: 2011-11-04 13:33 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
test.cs (902 bytes, text/x-csharp)
2011-10-26 08:08 UTC, Kari Takanen
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Kari Takanen 2011-10-26 08:08:32 UTC
Created attachment 769 [details]
test.cs

Doing "oProc.PriorityClass = System.Diagnostics.ProcessPriorityClass.Idle;" sometimes fails and sometimes works. A simple test program, which executes the "df" command multiple times, is attached.

Usually the command gets executed once and the program dies with

Unhandled Exception: System.ComponentModel.Win32Exception: Process not found
  at System.Diagnostics.Process.set_PriorityClass (ProcessPriorityClass value) [0x00000] in <filename unknown>:0
  at (wrapper remoting-invoke-with-check) System.Diagnostics.Process:set_PriorityClass (System.Diagnostics.ProcessPriorityClass)
  at Example.Test.Main (System.String[] args) [0x00000] in <filename unknown>:0

But sometimes it runs through the whole loop without errors.

Tested on Linux using Mono JIT compiler version 2.11 (master/91eb198 Tue Oct 25 10:16:19 EEST 2011).
Comment 1 Zoltan Varga 2011-11-04 13:33:30 UTC
This is not a bug, MS.NET also throws an exception if the process has already exited:

System.InvalidOperationException: Cannot process request because the process (3380) has exited.
   at System.Diagnostics.Process.GetProcessHandle(Int32 access, Boolean throwIfExited)
   at System.Diagnostics.Process.set_PriorityClass(ProcessPriorityClass value)
   at Example.Test.Main(String[] args)

Fixed mono to throw the same exception.