Bug 16834 - Getting build error when project and namesapce contain é
Summary: Getting build error when project and namesapce contain é
Status: CONFIRMED
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild ()
Version: 4.12.0
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2013-12-17 02:49 UTC by narayanp
Modified: 2013-12-17 13:47 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Test Project (13.37 KB, application/x-zip-compressed)
2013-12-17 02:49 UTC, narayanp
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 16834 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description narayanp 2013-12-17 02:49:00 UTC
Created attachment 5678 [details]
Test Project

Steps to reproduce:
1. Create an android application with name having French character (é)
2. Debug the application.

Actual Result: It is giving build error as mentioned in https://gist.github.com/saurabh360/62a51bbf359d1255826b

Expected Result: Project should deploy and launch successfully.

Environment details:
All Windows and Mac
X.S 4.2.3(build 20)
Mono 3.2.6
X.Android 4.11.0.210

Regression Status: This is happening with stable X.S 4.2.1 and X.Android 4.10.1-73
Comment 1 Peter Collins 2013-12-17 12:31:34 UTC
Diagnostic build:
https://gist.github.com/pjcollins/3209be6c676e3fd49491

This does not happen with projects that simply contain é or è, or both. I was *not* able to reproduce with my own sample by simply adding some accented characters, or by copying and pasting the project name into XS ( éqnéè ). I was however able to reproduce with the attached project.


Task "AndroidSignPackage"
		Using task AndroidSignPackage from Xamarin.Android.Tasks.AndroidSignPackage, Xamarin.Android.Build.Tasks, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
		Tool /usr//bin/jarsigner execution started with arguments: -keystore "/Users/petercollins/.local/share/Xamarin/Mono for Android/debug.keystore" -storepass android -keypass android -digestalg SHA1 -sigalg md5withRSA -signedjar bin/Debug/x_qn__.x_qn__-Signed-Unaligned.apk obj/Debug/android/bin/x_qn__.x_qn__.apk androiddebugkey 
		jarsigner error: java.lang.IllegalArgumentException: MALFORMED
		Tool /usr//bin/jarsigner execution finished.
/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/Android/Xamarin.Android.Common.targets: error : Tool exited with code: 1. Output: jarsigner error: java.lang.IllegalArgumentException: MALFORMED
 
	Task "AndroidSignPackage" execution -- FAILED
Comment 2 Jonathan Pryor 2013-12-17 13:47:27 UTC
As mentioned in: https://bugzilla.xamarin.com/show_bug.cgi?id=15559#c5

> The issue is (apparently) that we're not UTF-8 encoding filenames _within_ 
> the .apk/ZIP container: http://bugs.sun.com/view_bug.do?bug_id=6272251

I took a quick look at doing so; looks like we'll need to upgrade our Ionic.Zip.dll in order to UTF-8 encode filenames within the .apk.