Bug 16825 - WebView content does not display in Landscape orientation
Summary: WebView content does not display in Landscape orientation
Status: VERIFIED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Samples ()
Version: 7.0.4.x
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Amy Burns
URL:
Depends on:
Blocks:
 
Reported: 2013-12-16 14:02 UTC by Allie Miller
Modified: 2014-01-24 06:28 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Allie Miller 2013-12-16 14:02:13 UTC
When modifying the Load Local Content sample (http://docs.xamarin.com/recipes/ios/content_controls/web_view/load_local_content/)  to display content in landscape mode, the orientation of the content remains in portrait mode.

Steps to reproduce:
1. Open XS.
2. Debug and run sample application "Load Local Content" on device/simulator.
3. Change device/simulator orientation from Portrait to Landscape.

Actual Result:
The content inside the web view remains in Portrait mode when the device/simulator is in landscape mode. 

Expected Result:
The content inside the web view should display in landscape mode when the device/simulator is in landscape mode. 


Environment Details:
XS 4.3.0
Xamarin.iOS 7.0.5
Xamarin.Android: 4.10.2
Mono Framework 3.2.5
Comment 1 Marcelo 2014-01-07 10:13:37 UTC
This bug is preventing us to delivery the application to the customer, could you please give us an estimate about when it will be fixed?
Comment 2 Amy Burns 2014-01-07 16:11:47 UTC
Sample should now be working as expected. Tested on iOS7 and it rotates as expected. 

Fix:
https://gist.github.com/asb3993/8306895

@Marcelo is this the same issue you were getting?
Comment 3 Marcelo 2014-01-07 16:49:33 UTC
Thank you, it resolves the issue.
Comment 4 Saurabh 2014-01-24 06:28:55 UTC
I have checked this issue with latest master builds:

XS 4.2.3 (build 154)) 
Release ID: 402030154
Git revision: 4dca4a28d7ecc2c4df8a4d58e74b8902d0283b53
Build date: 2014-01-21 19:51:39+0000
Xamarin addins: cc120a6f639fa6649aa4d23a0f0e7c5701134047

Xamarin.iOS
Version: 7.0.7.64 
Hash: 094bb4e

Xcode 5.0 (3332.22)
Build 5A1412

I have downloaded sample application "Load Local Content" from following link:

http://docs.xamarin.com/recipes/ios/content_controls/web_view/load_local_content/

Now, content of WebView sample displays correctly in Landscape orientation on simulator and device.

Screencast: http://screencast.com/t/uc9hB1Sd

Hence, closing this issue.