Bug 1681 - Crash when instantiating strings
Summary: Crash when instantiating strings
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Android
Classification: Xamarin
Component: Mono runtime / AOT Compiler ()
Version: 1.0
Hardware: PC Windows
: --- major
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-10-25 12:59 UTC by Franco
Modified: 2011-11-01 22:31 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
The activity is able to create strings and cause the crash (25.03 KB, application/octet-stream)
2011-10-25 12:59 UTC, Franco
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Franco 2011-10-25 12:59:20 UTC
Created attachment 762 [details]
The activity is able to create strings and cause the crash

Creating a large number of strings will cause the activity crash.
I have added a test activity that creates strings in a loop.
On my device (HTC Desire HD) the crash happens after 2800 strings have 
been created.
Comment 1 Jonathan Pryor 2011-11-01 22:31:56 UTC
I'm going to guess that this was fixed in 1.9.2 (or some other 1.9.x release, as you don't mention which release this is breaking on).

If I start your app and tap the "Start test in UI thread" button, I (eventually) get:

I/Test    (13762): Test loop 2999
I/Test    (13762): Faked 600000 strings
D/dalvikvm(13762): GC_EXPLICIT freed <1K, 52% free 3242K/6727K, external 1625K/2137K, paused 37ms

And If I then click the "Start test in Background Thread" button, I (eventually) get:

I/Test    (13762): Test loop 2999
I/Test    (13762): Faked 1200000 strings
D/dalvikvm(13762): GC_EXPLICIT freed <1K, 52% free 3243K/6727K, external 1625K/2137K, paused 33ms

So I'm not able to reproduce.