Bug 1673 - Just selecting the attached Solution ( not loading it ) crashes MonoDevelop
Summary: Just selecting the attached Solution ( not loading it ) crashes MonoDevelop
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Project Model ()
Version: 2.8.1
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Lluis Sanchez
URL:
Depends on:
Blocks:
 
Reported: 2011-10-24 20:23 UTC by Dominique
Modified: 2011-10-26 06:34 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Blank solution that crashes MonoDevelop (430 bytes, application/zip)
2011-10-25 13:01 UTC, Dominique
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Dominique 2011-10-24 20:23:06 UTC
Just selecting the attached Solution ( not loading it ), from the Open Solution dialog box, crashes MonoDevelop!
Comment 1 Dominique 2011-10-24 20:25:33 UTC
I noticed that both my .userprefs and .suo files were 0 kb. Could that be the propblem? Maybe create those 2 files with nothing in them along side the solution file and try it.
Comment 2 Alan McGovern 2011-10-25 06:35:59 UTC
You haven't actually attached anything to the bug report. Would you be able to attach the necessary files to reproduce the issue?

Thanks!
Comment 3 Dominique 2011-10-25 06:59:49 UTC
Sorry Alan, I thought the Solution had been added. I couldn't add the other 2 files as they were 0kb. I'll have to do it later today.
Comment 4 Alan McGovern 2011-10-25 07:08:14 UTC
No worries. You can zip up any required files and just attach the zip archive if it makes things simpler. Thanks for taking the time to report the issue
Comment 5 Dominique 2011-10-25 13:01:27 UTC
Created attachment 763 [details]
Blank solution that crashes MonoDevelop
Comment 6 Alan McGovern 2011-10-26 06:34:39 UTC
The bug which caused the crash has been fixed now. I also added additional checks to prevent other similar issues from crashing MonoDevelop completely. This particular issue will only happen when you select a file which has less than 2 lines in it which has the 'sln' or 'csproj' extension. You hit the issue because your sln file is a zero byte file, it's empty.

Thanks for reporting the issue and let us know if you have any further problems.