Bug 16719 - iPhoneSimulator Target Running Only Retina 3.5
Summary: iPhoneSimulator Target Running Only Retina 3.5
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Debugger ()
Version: 1.8.x
Hardware: PC Windows
: High major
Target Milestone: 1.12 (Merge)
Assignee: Vinicius Jarina
URL:
Depends on:
Blocks:
 
Reported: 2013-12-10 22:52 UTC by developer
Modified: 2016-05-10 17:02 UTC (History)
16 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description developer 2013-12-10 22:52:43 UTC
Running 1.8 Visual Studio plugin with Mac Xamarin Studio 4.2.2 (build 2) with Xcode 5.0.2 (5A3005), when I do a debug build to the iPhoneSimulator I get always get the iPhone simulator retina 3.5 inch.  I would like to get the retina 4 inch. The issue also appears in StackOverflow here:  http://stackoverflow.com/questions/20050277/how-to-select-the-right-iphonesimulator-device-from-visual-studio-iphonesimula
Comment 1 developer 2013-12-10 22:54:51 UTC
It was also mentioned here:  http://forums.xamarin.com/discussion/9279/xs-debug-target-iphone-3-5-showing-iphone-4
Comment 2 Marek Habersack 2013-12-11 03:36:06 UTC
This issue is fixed in MonoTouch 7.0.4 - please make sure you use at least that version and reopen the bug should the issue still exist, thanks!
Comment 3 developer 2013-12-11 20:54:24 UTC
I have Xamarin.IOS Version: 7.0.4.209 and it still is occurring.
Comment 4 Nischal 2013-12-12 03:24:21 UTC
I have checked this issue with following builds and observing the same behavior. It always open iPhone retina 3.5 simulator on debugging the build.
Checked with iPhone retina 6.0, 6.1 and 7.0. Screencast for the same:
http://screencast.com/t/SUrqnrvAMZo

MTVS 1.8.365.0
Xam.iOS Version: 7.0.4.209 
XS Version 4.2.2(build 2)
Xcode 5.0.2 (5A3005)

Changing the bug status to confirmed.
Comment 5 René Ruppert 2014-02-10 09:58:40 UTC
Same issue STILL! Meanwhile VS 2013 and VS plugin 1.10 - guys, come on! This is important. Thanks.
Comment 6 Vinicius Jarina 2014-02-17 08:50:09 UTC
Hi @nischal @René

We tested here with the latest version (XVS 1.12 + MT 7.0.7 + Xcode 5.0.2 (5A3005)) and seems to be working fine with 3.5 and 4inch simulators http://screencast.com/t/IquEVhxjStHn
Comment 7 René Ruppert 2014-02-17 09:21:30 UTC
How can I get XVS 1.12? It's not available through Alpha channel.
Comment 8 Vinicius Jarina 2014-02-17 13:15:05 UTC
We are about to release René.
Comment 9 PJ 2014-02-17 13:39:39 UTC
Looks like this was resolved for 1.12 in comment 6. 
=> RESOLVED FIXED
=> 1.12
Comment 10 Mohit Kheterpal 2014-02-24 06:00:23 UTC
Today we have checked this issue with following builds :

VS 2012
Xamarin for VS 1.12.217
X.iOS

Now, we are able to deploy application on 3.5 inch and 4.0 iphone retina.

Hence, closing this issue