Bug 16670 - PutAsync method in System.Net.Http.HttpClient send the request as GET method
Summary: PutAsync method in System.Net.Http.HttpClient send the request as GET method
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: System ()
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2013-12-09 01:41 UTC by Prashant Cholachagudda
Modified: 2013-12-09 12:20 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Prashant Cholachagudda 2013-12-09 01:41:33 UTC
PutAsync method in System.Net.Http.HttpClient works perfectly in .Net application, but fails in Mono/iOS/Android.
Comment 2 Marek Safar 2013-12-09 04:52:53 UTC
What is not working?

 I get following response from the server using enclosed sample

2013-12-09 10:51:35.790 TestApp[71967:80b] [{"id":"1","user_id":"1","sum":"999","categoryId":"9","comment":"qwerty","datetime":"2013-11-21 23:03:22","account_id":"1","login":"test"},{"id":"2","user_id":"1","sum":"555","categoryId":"1","comment":"\u0442\u0435\u0441\u0442 2","datetime":"2013-11-21 23:00:28","account_id":"1","login":"test"},{"id":"3","user_id":"1","sum":"555","categoryId":"11","comment":"qwerty11","datetime":"2013-11-21 23:03:11","account_id":"1","login":"test"},{"id":"4","user_id":"1","sum":"9999","categoryId":"1","comment":"","datetime":"2013-11-26 22:17:41","account_id":"1","login":"test"},{"id":"8","user_id":"1","sum":"123","categoryId":"1","comment":"com","datetime":"2013-11-21 23:03:00","account_id":"1","login":"test"},{"id":"9","user_id":"1","sum":"111","categoryId":"11","comment":"qwerty11","datetime":"2013-11-21 23:03:11","account_id":"1","login":"test"},{"id":"10","user_id":"1","sum":"111","categoryId":"11","comment":"qwerty11","datetime":"2013-11-21 23:03:11","account_id":"1","login":"test"}]
Comment 3 Prashant Cholachagudda 2013-12-09 04:58:10 UTC
@Marek,

Sorry, I should have linked the desk case.

When we use PutAsync (in Mono) request goes to server as GET method

The sample should return you only 
{"id":"2","user_id":"1","sum":"555","categoryId":"1","comment":"\u0442\u0435\u0441\u0442
2","datetime":"2013-11-21
23:00:28","account_id":"1","login":"test"}
Comment 5 Marek Safar 2013-12-09 08:18:56 UTC
Fixed in master